WordPress Security Essentials : Four Points Of Vulnerability

Part 2 of our WordPress Security Essentials video series and today it’s all about you.

It will walk you through the four points of vulnerability, responsible for almost every successful hack attack, and offer plenty of suggestions for what you can do to minimize them.

No rocket science. No complicated procedures. Just good ol’ plain common sense.

The most valuable security measure is properly managing your WordPress site
The most valuable security measure is properly managing your WordPress site

Almost every successful hack of a WordPress site exploits one or more of the four main points of vulnerability:

  1. Host security breach
  2. Out-of-date WordPress Core
  3. Unsafe plugins and themes
  4. Brute force attack

If you don’t manage these areas well, then any additional security measures you take will be in vain. You most valuable security tool is good management of your WordPress site.

In this video, we’ll cover what that good management entails:

  • Choosing the right host
  • Keeping your version of WordPress up-to-date
  • Selecting new plugins and themes
  • Managing existing plugins and themes

Useful resources:

Tags

Comments (5)

Participate