Admin Menu issue - Insufficient Permissions

Hello,

I created a website for a client and used the Adminimize plugin to customize the Admin Menu. However, it removed one plugin from the menu even though it was not selected. Deleting the plugin did not rectify the situation.

I tried adding a direct link to the plugin page using your Ultimate Branding plugin however, it continues to give the client the "You do not have sufficient permissions to access this page." error message.

Any ideas on how to remove the settings from the database and also customize the menu using a different plugin?

Thanks!

    Brashell

    Yes, deleting it would have done you no good as the data is stored in the database as a permission. Download http://wordpress.org/plugins/advanced-access-manager/ onto the site, and set the user to have the permission. In the General metabox select the role he has for the site, then go to capabilities and select the ones that are applied to the plugin. Let me know if you need more help, I will guide you more in depth if needed. Cheers!

    Brashell

    Anything that can change permissions is fine.

    ticadmin
    • Elite
    • 298
    • #335

    Hi and thanks for the input.

    I Installed Advanced Access manager but I do not see any capabilities that are applied to this particular plugin (CalPress Calendar http://wordpress.org/plugins/calpress-event-calendar/)

    I did install Admin Menu Editor previously and it did not change anything.

    Thanks for your help!

    DavidM

    Hi Steve,

    I've just tested using Admin Menu Editor alongside CalPress and am seeing the CalPress Events menu item amidst the Admin Menu Editor options, as shown in the attached.

    To verify, you're not seeing that when you use Admin Menu Editor, correct?

    If that's the case, would it be possible for you to disable all other plugins to see if there's a conflict elsewhere?

    Thanks!
    DavidM

    DavidM

    Whoops, forgot the attachment!

    ticadmin
    • Elite
    • 298
    • #335

    Hello David and thank you for your help.

    I apologize. The plugin which is not showing up on the side menu is the WPMU Appointments+ plugin.

    I tried using Menu Editor to make it available to the Editor User Role but with no success.

    I believe the Adminimize settngs are still fouling things up but not certain.

    Thanks

    DavidM

    Hi Steve,

    I'm still seeing the same possibility on my test site. Appointments+ still is available in the Admin Menu Editor.

    I really can't see Adminize settings being at fault here if the plugin is disabled. The plugin can't do anything with permissions unless it's activated.

    Have you tried disabling other plugins to see if there's a conflict?

    Is the issue that you're trying to set it to only show for editors but it's not showing or maybe is showing for all roles?

    Thanks,
    DavidM

    ticadmin
    • Elite
    • 298
    • #335

    Hi David,

    Brashell initially said above that "Yes, deleting it would have done you no good as the data is stored in the database as a permission."

    This is what appears to be happening. It's all rather difficult to explain without seeing it but basically this is what transpired:

    1. Installed and set permissions on Adminimize. I did not limit access to Appointments+ although the plugin did remove it from the sidebar area from all user roles accept Admin.

    2. I deleted Adminimize, however, all the Adminimize changes remained when logged in as an Editor.

    3. I installed Menu Editor hoping it would allow me to change the permissions but it did not.

    So from my vantage point it does appear that the Adminimize changes have been stored in the database.

    Thoughts?

    DavidM

    Hi Steve,

    I realize how confusing that can be but it honestly sounds like an issue with user role capabilities and not with any of the admin menu plugins.

    Are you using any user role or capabilities managers like Capman, Members or User Role Editor?

    Thanks,
    David

    Brashell

    @steve_tullius

    This is going on for long enough, email me at admin@edutasc.com attach the plugin who's menu you can't access and the role of the person who isn't able to see the menu. I will recode it so that the menu will display for that users role. Please zip the folder. I will get it back to you in a few hours once I finish up my work. Cheers! - Brashell

    Brashell

    Also, please use the one in your files for the site and download it using some sort of FTP. I don't want a fresh install version as you might have had some rogue plugin mess up a file or you made an accidental change. Whether you know it or not you made a change somewhere in the file or a plugin did it happens.

    Brashell

    Also is this Multisite or Single Site?

    DavidM

    Hi @steve_tullius,

    Just checking in on this one. I'll be happy to have a look with this as well if it's not sorted already.

    If you need any help still, please feel free to send admin details through the contact form here:
    http://premium.wpmudev.org/contact/

    Just select "I have another question" and for the subject include "ATTN David". I'll be able to trace it back to this post.

    Thanks,
    David

    Alexander
    • 53
    • #2,342

    I have the exact same issue. (I need to keep using adminimize)

    I think I just need to add the correct custom capability.

    E.g. wpc_add_clients

    I'm using the members plugin to handle custom roles:
    http://themehybrid.com/plugins/members

    Alexander
    • 53
    • #2,342

    Anybody know what is the correct capability? It seems there is a conflict with Adminimise or "members" plugin.

    Jack Kitterhing

    Hi there @Alexander,

    Hope you're well today and sorry about the delay on this.

    The best way here would be to test for a plugin conflict using the attached screenshot :)

    Thanks!

    Kind Regards
    Jack.

    Alexander
    • 53
    • #2,342

    That didn't solve the issue. It was the first thing I tried.

    As per the other thread, you can see it's capability issue. See first comment. Any idea which capability this plugin requires to access the settings page?

    Jack Kitterhing

    Hi there @Alexander,

    Hope you're well today, I've just taken a look through this complete and can you confirm if it's the appointments+ plugin like Steve that also isn't showing for you?

    I can take a look at the capabilities once I know which plugins.

    Thanks.

    Kind Regards
    Jack.

    Alexander
    • 53
    • #2,342

    That;'s the one! Appointments+.

    I can't get to the settings to tweak anything.

    It's the identical issue.
    1) I use the plugin members to handle custom roles and capabilities.
    2) As well as adminimize

    aristath

    Hello there Alexander,

    Could you please grant us access to your backend so that we may see exactly what is happening?
    To do so, from your dashboard go to WPMUDEV => Support => Support Access and click on the "Grant access" button.

    Cheers,
    Ari.

    Alexander
    • 53
    • #2,342

    Support is inactive in my dash. I'm just asking for the capability as per the thread that needs to be allocated so I can access the settings page. This should at least be findable in the forum or the plugin support docs somewhere.

    It's a permissions issue due to a capability not being present with custom roles. What's the capability required for this?

    aristath

    From what I can tell from the plugin code users must have the "manage_options" capability in order to access the plugin settings.

    You can then enable the "Administrative Permissions" addon to define these in more detail.

    I hope that helps!

    Cheers,
    Ari.

    Alexander
    • 53
    • #2,342

    Hi Ari

    I already have that option enabled and it doesn't work.

    There is a specific capability that is needed to access the settings page.

    What is this custom capability?

    Jack Kitterhing

    Hi there @Alexander,

    Hope you're well today.

    I've just checked appointments+ and there isn't a custom capability for this, it is manage_options after checking the code.

    Are you also using the appointments+ permissions add-on? If you are, can you disable the plugins so you can get to deactivate that and then re-enable the plugins and it should work.

    Unless you have modified the capabilities at all?

    Thanks!

    Kind Regards
    Jack.

    Alexander
    • 53
    • #2,342

    Hi @Jack Kitterhing

    Well thanks, just trying to get this resolved. My issue is exactly as per the OP in this thread.

    1) manage_options is enabled since it's the default administrator role. I've just added extra roles, and haven't edited the admin role or capabilities at all.
    2) Yes, using permissions addon. Issue is that it is under the settings tab which I can't access so can't activate and deactivate. I've tried changing theme to default, deactivating all plugins, and still it won't let me access. Exact same issue as the OP in this thread.

    Can you try a blank install of appointments+, then install members and adminimise plugins.

    http://wordpress.org/support/plugin/adminimize
    http://wordpress.org/plugins/members/
    Then just delete the following roles as they are not needed:
    editor, contributor, subscriber.
    Leave admin untouched.

    Then try and access settings. You'll see that Appointments+ somehow locks out the admin! So I'd guess that there is some custom capability in the plugin that is linked to one of these roles, but no idea why it should be impacting the admin role!

    Exact same issue as the OP.

    Jack Kitterhing

    Hi there @Alexander,

    Hope you're well today and thanks for the extra information.

    I can indeed replicate this issue, though I can't see any custom capabilities in the plugin, I'm including the lead developer of Appointments+ @Vladislav here.

    Thanks!

    Kind Regards
    Jack.

    Alexander
    • 53
    • #2,342

    @Jack Kitterhing

    Always good when an issue can be replicated! You'll see those are two very prominent role/capability plugins that have been recommended a few times on WPMUDEV in different posts.

    When an issue can be replicated, it can be solved. ;-)

    ticadmin
    • Elite
    • 298
    • #335

    Hello, I am still very interested in a solution to this issue. Thanks for bringing it back up Alexander!

    Vaughan

    Hi Alex & Steve,

    I have just emailed the developer of appointments & asked if he could take a look into this shortly. As it's Easter weekend, it could be a bit of a delay before he responds. Nut he is aware of the thread & will respond when he has looked into it.

    Thanks for your patience.

    Jack Kitterhing

    Hi there @Alexander and @steve_tullius,

    Hope you're both well today, could you verify which version of A+ you both have installed?

    I was testing on 1.4, after an upgrade to 1.4.2 it fixed the issue, as there was a permissions fix in 1.4.1, please advise :)

    Thanks!

    Kind Regards
    Jack.

    ticadmin
    • Elite
    • 298
    • #335

    Hi Jack, this issue was from quite some time ago and I have not been able to test it lately as I had to go with a different option. Currently I have been using the Add on for Admin Permissions but I would like to be able to use Adminimize in the future. I'll be interested in hearing how things turn out for Alexander.

    Jack Kitterhing

    Hi there @steve_tullius,

    Hope you're well today and thanks for the additional information.

    This should technically be fixed in 1.4.1 and it does appear to be working correctly now, if you wanted to try it, but no worries if not :)

    Thanks!

    Kind Regards
    Jack.

Join 376575 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member