Can't get no access page to come up

I am tying to block the account page so that only members can get to it and have it go to my no access page instead of the 404 page. I can get it to go to the 404 page just fine but I'd rather have my own message. I created a no access page and selected it in the drop down under protected page content. Also selected yes to override 404 with this page. In the edit levels section I put pages in the negative rules and selected the account page for the visitors level. I checked out this tutorial http://premium.wpmudev.org/blog/create-a-simple-tutorial-site-with-the-wpmu-dev-membership-plugin/ but it's not helping with the no access page. I am using the iThemes Builder which I am thinking is the issue. When I have it setup to show a 404 page it shows it even when I have override set in membership when I don't have the 404 setup on the theme it goes to the homepage. I am wanting to know if I did all I can with Membership before I head over to iThemes to see if it's the theme. It's much easier changing some settings on a plugin then digging into the themes code for me.

    Charles
    • 61
    • #2,032

    It seems my theme is causing Membership to not give me the no access page. I don't know much about PHP but I can tell that the 404.php file redirects to not_found.php. I was able to edit the text in that file to sound a little better but I would still like it to use the no access page instead because it's a little easier to edit than grabbing the php files. Can I have Membership look for the not_found.php file instead of 404.php in order for Membership to override it?

    Philip John

    Hiya,

    First off you should check if it really is your theme by activating the default WordPress and testing to see if you still get the issue.

    I also notice you have Pages in your negative rules. This will cause any page accessed to use the no access page. However, as your no access page IS a page it will be protected by that rule.

    Membership effectively hides the pages from WordPress so it will return a 404 because Membership is telling it that no pages exist.

    You should add your no access page to a positive rule and make sure it isn't covered under your negative rules.

    Phil

    Charles
    • 61
    • #2,032

    I tried the default theme and several of the themes from here at WMPU DEV. The no access page is not coming up on any of them. They seem to have their own 404 message for example Magazeen by Spencer Theme:
    This page has either been removed, or was possibly never been created. Try some of the links below to find your way around the site.

    Twenty Ten says:
    Apologies, but the page you requested could not be found. Perhaps searching will help.

    I tried to set up pages in both negative and positive rules which is confusing me a bit now. I thought if I put pages in negative only the ones I check have that rule apply. So if I put pages in the negative and check account then only the account should be restricted correct? That is the way I had it and it was restricting who sees it I just wasn't getting the no access page showing up but all the other pages were showing up fine.

    Philip John

    Can you try removing the pages from the negative rule completely and adding a positive rule for the no access page only please?

    Meanwhile, I'm asking some of my colleagues to jump in here and take a look too.

    Phil

    Charles
    • 61
    • #2,032

    I took the pages out of negative and put them in positive. I checked just the no access page and still not getting the no access page. Last night I tried blocking a category (to see if it made a difference) by using both negative and positive rules just like with the pages and I get the same issue. Other than directly going to the no access page by typing it in it doesn't show up.

    imbadash
    • 28
    • #4,610

    The only way i've gotten the no access page to come up is by setting the 'stranger settings' to "None-no access to content" the only problem with that is then a new visitor to the site sees absolutely nothing but the no access page so they can't browse around.

    As soon as i create a new level like 'visitor' and tell membership that they can view specific pages, and the no access page to restricted areas i'm back to getting the 404 error page when they should see the no access page.

    Charles
    • 61
    • #2,032

    Thanks imbadash! I finally got the no access page to show up. Like you said though, it blocks them from seeing things I don't want to block. Strange thing is that the content on my blog page is blocked with the 404 message coming up and not the no access message. I was able to get the no access to show when I tried getting to the account page. I think I am just going to let the 404 do it's thing until I can get this figured out.

    Charles
    • 61
    • #2,032

    Strange! I have been busy for a few days so haven't worked on my site. Decided to check it out today and now my blog page is getting either the no access page or the 404 page depending on what I have set. This is when I have it set to visitor so they should be able to see my blog. When I changed it to stranger again I ended up with a bunch of code showing up in my background above the header and in my left sidebar between two widgets. I put the pages in negative and just clicked the account page and all that mess went away. It was working fine a few days ago when I last touched it which doesn't make much sense. Gottta love technology!

Join 376444 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member