Can't get rid of comments on my front page

Hi there again. I have a rather irritating problem. Even though I have unchecked the "allow comments" "allow trackbacks and pingbacks" boxes on my front page, comments are appearing. I use the front page to show recent network posts using the following code:

[globalrecentposts number="10" title_link="yes" show_avatars="yes" content_characters="160" avatar_size="48" ]

Is this relevant to my problem - or have I just done something silly elsewhere? My site is blogg.fu.ntus.se

    Jack Kitterhing

    Hi there and thanks for your question.

    I see the comments box on the page, have you disabled comments on the page, by editing that page and disallowing comments?

    If you want to hide the comment form you can add this to your css

    #commentform {
    	display: none;
    }

    Or you can remove the comment_form php code from your theme :)

    Which way would you rather go?

    Thank you!

    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Hi there again.
    Before I go any further I must report that I hadn't realised that I wasn't logged in - and consequently couldn't see the reply box - duhhhh!

    The comments are disabled ( well the "allow comments" box is not ticked ) which is what disturbs me, and which suggests that there is some sort of conflict with your code.

    [globalrecentposts number="10" title_link="yes" show_avatars="yes" content_characters="160" avatar_size="48" ]

    When I remove the recentposts code the comments disappear. The appearance of the comments form is directly related to your app. Is this a bug or a feature?

    Jack Kitterhing

    Hi there @ntus

    I hope you are well today and thank you for the additional information.

    I have tried to replicate this but unfortunately can't, one thing I did think of is, are the posts across the network that your pulling in, also have comments disabled? Or just the main site, if just the main site, can you try disabling them across the network and see what happens then please? :)

    Don't worry we will get this resolved :)

    Thank you!

    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Hi Jack. There are 30 sites just now and I am sure that most, if not all, will have comments on. I'm not sure what setting I should change. Here are all the comment settings:
    comment notify 1
    default comment status open
    default ping status open
    comment moderation 0
    comment whitelist 1
    comment registration 0
    page comments 0

    Is there any chance of losing comments permanently if I change any of these settings

    Jack Kitterhing

    Hi there @ntus

    I hope you are well today.

    Did you want any of the sites to be able to use comments? As if you didn't and you wanted comments removed completely, we could use the CSS I posted and remove one file :)
    Please advise, changing those settings wouldn't permanently remove comments.

    Thank you!

    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Hi Jack. I'm well and hope you are too.
    All of the subsites use comments - and wish to keep them. It's only the front page where comments aren't particularly appropriate.

    Jack Kitterhing

    Hi there @ntus

    I hope you are well today, this is quite strange, I can't replicate this, are the sub sites using the same theme on the main site/front-page? If they aren't the CSS will work I posted by placing that in the theme or if not we can find a workaround, please advise :)

    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Hi Jack. The front page is twentyten and the vast majority of the subsites use twentytwelve, but there are one or two subsites that also use twentyten. Your inability to replicate my problem suggests that I may have a totally illogical parameter setting - a setting that you wouldn't expect me to have. I could have done something really illogical/stupid (through lack of awareness). This is essentially an irritation, not a show-stopper and I don't want to modify code unless it is absolutely necessary. If we can't arrive at a logical conclusion to the issue, I'll let it drop - or maybe change the front page theme (although I really like twentyten's simplicity).

    mbeneteau

    Hi ntus,

    Can you show me the link of the homepage where the comments is showing.

    And did you enabled a static page from posts or pages in the homepage, if yes you can just disable the allow comment option from:
    Dashboard > posts> all posts > quick edit the post you have used as Static on home page > and untick the allow comments option

    If you have made a Static page in your homepage then:
    Dashboard > pages > all pages> quick edit the page you have used as Static on homepage > and untick the allow commnets option

    Let me know if this helps you, if you have made a static or sticky Post/Page as Homepage.

    Jack Kitterhing

    Hi there @ntus

    I hope you are well today, it certainly is strange.

    Can you install this plugin http://wordpress.org/plugins/my-custom-css/ (only activate it on the main site), don't network activate.

    Then add the CSS I gave you and that will remove the form, if that would work for you?

    Thank you!

    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Hi mbeneteau - thanks for your post.
    The site is blogg.fu.ntus.se. It uses a static front page - and the "allow comments" box is indeed unticked.

    ntus
    • Elite
    • 46
    • #2,486

    Hi Jack
    I installed "my custom css" - which is a much better option than editing theme code. Your code worked, to a certain degree. It took away the comment form but it left behind the text: "Leave a Reply". We're almost there!

    Jack Kitterhing

    Hi there @ntus

    Great! Add this

    h3#reply-title {
        display: none;
    }

    And that should do it :)

    Thank you!
    Kind Regards
    Jack.

    ntus
    • Elite
    • 46
    • #2,486

    Sorted !!!!!!!!!!!!

    Thanks for all your help Jack. I must say that I really like the idea of my-custom-css. It really removes a potential headache from the update process.

    Jack Kitterhing

    @ntus

    Your most welcome :) I'm glad it's all sorted out :)

    My-custom-css, is certainly a great and very useful makes it easy to add custom css to only one site on a multisite (works on single site installs too), and of course like you say, it removes the headache of the update process or creating child themes etc :)

    If I can be of any further assistance please don't hesitate to ask.

    Thank you!

    Kind Regards
    Jack.

Join 366163 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member