Default Header image is appearing on each post

Another issue bugging me on bp-social theme is, on each post I can see the default header image appearing at the top..!! Please let me know how to prevent this from displaying.. If I have any image on my post, it should show. Otherwise, it should be blank.. Kindly help me ASAP..
Thanks in advance.

    psivait

    What I infer from the bp-social theme is, even though if you don't have any image on a post, a default image (header image) is being populated.. If I have any image on a post, that particular image is fetched correctly and being displayed. The former case is meaningless, and I believe, small codes have to be commented/removed. Please guide me on this part at the earliest.
    Thanks in advance.

    Richie_KS

    hi
    opne bp-social/functions.php go to line 519+
    you should find some code like this

    if(!$get_post_attachment) {
    
    $attach_img =  get_bloginfo('template_directory');
    $sImgString =  $open_class . '< a href="#" >' . '< img src="' . $attach_img . '/_inc/images/header.jpg' . '" class="full" />' . '< /a >' . $close_class;
    echo "$sImgString";
    
    } else {
    
    $sImgString =  $open_class . '< a href="#" >' . '< img src="' . $get_post_attachment . '" alt="ui" class="full" />' . '< /a >' . $close_class;
    echo "$sImgString";
    
    }

    comment out the first code before } else {..to like this

    /*
    $attach_img =  get_bloginfo('template_directory');
    $sImgString =  $open_class . '< a href="#" >' . '< img src="' . $attach_img . '/_inc/images/header.jpg' . '" class="full" />' . '< /a >' . $close_class;
    echo "$sImgString";
    */

    cheers

JOIN 396028 HAPPY MEMBERS

We pride ourselves on our level of customer support and responsiveness to member requests. Your WordPress experience will never be the same


Start free trial