Domain Mapping Tip - not parked but subfolder

I have an hosting account that manages all my domains on Bluehost. Buddypress/WPMU is in a subfolder on that account and not the primary domain. I wanted to take another domain and point it to a Buddypress blog but it kept showing the Primary domain, not the Buddypress domain or the blog within buddypress.

This is probably really obvious to all the clever clogs developers out here but I'm not one of them.
I mucked around with A names and Cnames and Parking and goodness knows what else forever and ever (about 4 hours) and finally figured out that I should IGNORE the "If your domain name includes a sub-domain such as "blog" then you can add a CNAME for that hostname in your DNS pointing at this blog URL. If you want to redirect a domain you will need to add a DNS "A" record pointing at the IP address of this server: blah.blah.blah.blah" message

All I had to do was go to CPanel, click Domain Manager, select my new domain name and point it to the main subfolder that WPMU was in. Once MyBlog.com was pointing to Buddypress.com, it found xyz.buddypress.com (set up in Tools/Domain Mapping).
I think under other situations and maybe on other hosting services you have to do that other stuff in Simple DNS Zone Editor (cpanel) but I just wasted time in there.
Hope this helps someone :) - and yes it's really obvious. Now. :P
Cheers Laurel

    culturepod
    • 4
    • #18,123

    Hello,

    Thank you so much for posting this!

    I have this same issue. WPMU is in a subfolder and mapping is pointing to the main blog.

    By "point it to the main subfolder that WPMU was in." do you mean by using "domain forwarding" "host @ record" or something else?

    Appreciate your help!

    Aaron

    @culturepod, if you give us the specifics we can help you out.

    culturepod
    • 4
    • #18,123

    Hello Aaron,

    Right now I have 2 Wordpress installs on my host account. A single WP install on the root and a WPMU install in> /directory (WPMU in subfolder)

    Domain is in godaddy:
    - added the A record that points to the server IP to the domain name in DNS (left NS parked)
    - added the server IP to domain mapping settings in WPMU admin
    - added "domain.com" to "custom domain" column in mapping plugin settings. (after hitting save I noticed it automatically adds the "/directory" after the domain I entered here.)
    - waited 12 hours for the domain to propagate.

    Now "domain.com" points to the root blog in the: /directory (WPMU in subfolder)

    Any help would be great!

    Aaron

    Ok, this step:

    - added "domain.com" to "custom domain" column in mapping plugin settings. (after hitting save I noticed it automatically adds the "/directory" after the domain I entered here.)

    is specific to the blog you want to map. You need to remove this from the main blog, then go into the backend of the blog you want to map and add your domain there.

    culturepod
    • 4
    • #18,123

    "You need to remove this from the main blog"

    Sorry not sure what you mean by remove it? Where do I remove it from?

    I checked all options under:
    - main-blog-admin/settings
    - main-blog-admin/settings

    Is it somewhere else I am missing?

    Thanks!

    Aaron

    In the back end of your main blog, go to tools->domain mappping and unmap that domain. Then go into the back end of the blog you want to map and register it there.

    drmike

    A single WP install on the root and a WPMU install in> /directory (WPMU in subfolder)

    (after hitting save I noticed it automatically adds the "/directory" after the domain I entered here.)

    Just for reference, if I caught you on one of my servers doing this, you would be booted asap. Many hosts would consider this server abuse as you;re doing three redirects on top of one of another. This is one of the reasons why the folks helping out on the mu forums refuse to cover this normally. (edit: And as an aside, you;re using Godaddy and they're well know for booting any client as soon as they have any server load.)

    WPMu needs to be in root, not a subdirectory. That's the reason why you;re getting the directory attached to the urls. You need to have wpmu from where the blogs are being directed off of from.

    Even if you cover it up with the domain mapping, you;re going to have issues with plugins.

    I would think that best bet would be to install wpmu into the root and your wp install as a blog within your mu site.

Join 368221 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member