Facebook Comments: facebook url is unreachable

I have the Facebook comments enabled on the site, and I'm having a bizarre issue: when I publish a new post, the Facebook comment section has an error that says the URL is unreachable. If I click on the link it takes me to a Facebook status page where it looks like it's trying to debug the issue...but it says it has a 200 success message and if I go back to the page and click refresh the error goes away.

Any thoughts as to why it's showing this message but after I click on the link it goes away? I think I have my Facebook app settings correct. The domain is just herviewfromhome.com and the Site URL is http://herviewfromhome.com/

Thank you!

-David

    Kimberly

    Hello there David!

    Did you make any changes to the Advanced portion of the Facebook App? Specifically the offline access permissions?

    Also, do you get this with the default twenty theme?

    Here is what I get when running your url through the Facebook debugger :)

    controlyours

    Hi Kimberly,

    Thank you for your suggestions!

    I double checked the Facebook debug tool and was able to remove those warnings that you presented in your screenshot but that didn't help resolve my issue. I don't have the "Remove offline_access permission" option disabled in the Facebook app advanced settings, and the error message (see screenshot for example) still shows up in the default twenty theme.

    Any other ideas? I'm so perplexed!
    Thank you!

    -David

    Kimberly

    Hey David!

    I've been in touch with the developer on this and he is perplexed as well. He has asked that I flag him on this ticket so he can take a closer look :)

    Thanks!

    controlyours

    Hi Kimberly,

    Thank you so much! Wow, the support on WPMUDEV is unreal awesome! :D

    -David

    Vladislav

    Hello,

    Just a quick question, has anything changed on the site? I have checked the posts linked from the home page like a day or two ago and saw the issue you described, but on a quick inspection everything seemed to be in order. However, when I checked the pages yesterday and today, the comments were showing fine, without any warning message. Can you please confirm if that's the case for you too?

    controlyours

    Hi Vladislav,

    I just went to the website and the latest post isn't showing the error message but that's probably because they clicked on the link already and cleared the message out. You can see the error message on this post which was posted yesterday: http://herviewfromhome.com/her-pinspiration-spooky-spider-soap/

    Let me know if you have any suggestions. I'm so lost as to why it's doing this.
    Thank you!

    -David

    Tom Eagles
    • Monthly
    • 15
    • #7,973

    @controlyours

    Just checking in to see if everything is resolved or if you are still having problems, if so please let me know

    Cheers!

    Tom

    controlyours

    Hello,

    Anyone? It's been several days now...chirp chirp. :)
    Any suggestions?

    Thank you!

    -David

    Tom Eagles
    • Monthly
    • 15
    • #7,973

    @controlyours sorry for the delay pinging the dev again for you.

    Vladislav

    Hi,

    Unfortunately, I still haven't really been successful in replicating the issue. However, I did found some related bug reports from people that are experiencing a similar issue: http://developers.facebook.com/bugs/435541079801474/ and http://developers.facebook.com/bugs/330033563744935/ . Going by these, it appears there's an odd Facebook bug that causes this to happen. Fortunately, both bug reports have been recognized by Facebook and there's a pending patch to fix them. Hopefully they'll be resolved very soon.

    controlyours

    Got it, thanks Vladislav. I really appreciate you looking into it.

    -David

    Tom Eagles
    • Monthly
    • 15
    • #7,973

    Hello, hope you're well.

    Just following up on some threads here and noted that we've not heard from you in a while.

    If you're still looking for some assistance on this thread then please by all means reopen it or create a fresh thread for any new questions.

    Take care.

    controlyours

    Hi Tom,

    The issue is still taking place. I've updated the plugin to the most recent version and that still didn't resolve anything.

    Let me know if you have any suggestions.
    Thank you!

    -David

    Tom Eagles
    • Monthly
    • 15
    • #7,973

    @controlyours

    There was a new release today with some additional features added. Although this doesnt affect your problem as its a facebook issue you should update anyway.

    Cheers

    Tom

    Kimberly

    Hey David,

    Just checking in here, how's it going on your end?

    Changelog was pretty big on last update, Ve tried to account for your issue directly in there.

    Let us know if you're still having trouble :)

    Happy New Year!

    Kimberly

Join 374868 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member