FATAL ERROR

Fatal error: Cannot redeclare class URI_Template_Parser in /home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/external/google/external/URITemplateParser.php on line 30

That's all I see now!!!!! HELP!!!!

    Patrick

    Hi @sebassinc

    Looks like you just installed the Google+ plugin and it hit a conflict with something.

    To track that down, we'll need to first deactivate that plugin. Using your FTP client (or the File Manager in cPanel if you prefer that), open your wp-content folder, then change the name of your plugins folder to DISABLEDplugins.

    Once you have saved the new name, you will be able to view and log in. Go to wp-admin on your site and go to "Plugins". You will see that all plugins have been deactivated. Now change the name of the plugins folder from DISABLEDplugins back to plugins .

    Finally, refresh the "Plugins" page in your wp-admin and re-activate the Google+ plugin only.

    Does it work? if yes, then there is definitely a conflict with another plugin that you had previously running on your site.

    If the error appears again, there is likely a conflict with your theme.

    We'll work from there.

    sebassinc
    • 21
    • #5,597

    So the plugin works now. I then activated:

    Google Analytics for Wordpress
    Infinite SEO
    Widgetkit
    WPMUDEV Dashboard
    Wufoo Shortcode Plugin

    When I tried to activate your Google+ Plugin this happened:

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot redeclare class URI_Template_Parser in /home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/external/google/external/URITemplateParser.php on line 30

    Vaughan

    Hi @sebassinc

    can you try as before, then make sure that google+ is the very first plugin that you activate.

    if everything works ok then, leave it activated & activate all the other plugins 1 at a time until the error re-occurs.

    if it fails when google+ is the only plugin you have tried to activate, then this would mean that your theme could possibly be using it too.

    Vaughan

    as a temp measure you could open

    wpmu-dev-plusone/lib/external/google/external/URITemplateParser.php in an editor

    then find

    class URI_Template_Parser {

    add the following just before. so it looks like >

    if(!class_exists('URI_Template_Parser')) {
    class URI_Template_Parser {

    then scroll to the end of the file and add a closing } around line 210

    so it looks like >

    public function __toString() {
        return $this->template;
      }
    }
    }
    sebassinc
    • 21
    • #5,597

    Activated Google+ first and it worked with no error. Then activated appointments next and I got the FATAL ERROR from the first post.

    My theme does automatically place a Google+ button on my posts.

    Vaughan

    ok, that's the problem. it is the google+ plugin, as appointments+ also uses that class, but the google+ plugin is missing the if(class_exists()) line.

    the solution i posted above will fix it, I'm sure the developer will update his plugin shortly.

    Patrick

    Hi @sebassinc

    The solution provided by @Vaughan is a good one. I'll flag the developer on this issue too.

    There's one other thing that needs to be tested: please activate the Twenty-Twelve or Twenty-Eleven theme on your site, with only the Google+ plugin running. This way, we'll see if it your theme which is conflicting.

    @Vaughan

    Good job sir!

    sebassinc
    • 21
    • #5,597

    I just fixed the code and everything works as planned.

    Thank you very much!

    Patrick

    @sebassinc

    Excellent!

    Thanks for confirming :)

    Vladislav

    Hello,

    The latest plugin release (v1.4, just released) should have a fix for such conflicts with other similar external library inclusions. Can you please update and see if it helps?

    sebassinc
    • 21
    • #5,597

    After updating the plugins for both appointments and G+ I now get the following:

    Warning: require_once(/home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/external/google/contrib/Google_plusService.php) [function.require-once]: failed to open stream: No such file or directory in /home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/class_wdgpo_google_auth.php on line 444

    Fatal error: require_once() [function.require]: Failed opening required '/home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/external/google/contrib/Google_plusService.php' (include_path='/home/sebassin/public_html/wp-content/plugins/appointments/includes/gcal:.:/usr/lib/php:/usr/local/lib/php') in /home/sebassin/public_html/wp-content/plugins/wpmu-dev-plusone/lib/class_wdgpo_google_auth.php on line 444

    Vaughan

    Hi @Sebassinc

    could you possibly start a new thread for this new error, as it will be less confusing to others. as this latest error is completely unrelated to the original thread title.

    i'll mark this thread as resolved.

    thanks.

Join 368713 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member