How can I only have Facebook comments displayed under a post?

I have gone through the settings and have checked:
-use facebook for comments
-override wordpress discussion settings

Unfortunately, the it seems the wordpress discussion settings are overriding the plugin's command. It seems I can only display Facebook comments, if I'm also enabling Wordpress comments on my post.

I am using a theme that has integrated discussion settings controls on each post page - allowing us to select to show, hide, or use default settings for displaying comments on each post. I've also tested each of these settings to see if I could display only Facebook comments, but it did not work.

I am able to hide the default comments using CSS, which achieves the desired effect but I don't want to rely on styling.

Any idea how to resolve this issue?


    • 14
    • #9,153

    I'm also wondering if there's a way to insert the comments into a post, as opposed to below the post (where they default to now)

    Is there a shortcode that could be generated to accomplish this?


    Greetings tbreschi,

    Welcome to WPMU Dev!

    I'm also wondering if there's a way to insert the comments into a post,

    Not that I am aware of with Ultimate Facebook but this may be accomplished using Facebook Comments for WordPress plugin

    Let us know how it goes if you choose to give it a go.

    Thank you for being a WPMU Dev Member!

    Cheers, Joe

    Arun Basil Lal
    • 3
    • #23,479

    Hey tbreschi and Joe,

    The problem description was a bit unclear to me, but let me take that you are trying to show just the Facebook comments and disable WordPress discussion completely?

    In that case, you can disable WordPress comments via the theme template and then insert the Facebook comments via the advanced hook.

    Check this out:

    Regarding inserting comments to a post, how exactly do you want this? Show comments from one post on another page (just the comments)?

    • 14
    • #9,153

    Arun, thanks for the tip - and quick response.

    I'm sure this would have solved the problem, but just out of curiosity I had to try the new plugin released by Facebook.

    It takes care of this issue.

    Thanks again for your help.



We pride ourselves on our level of customer support and responsiveness to member requests. Your WordPress experience will never be the same

Become a member

  • PayPal Partner