Q&A Plugin Style Issues in Single Question/Answer Area

Hi

I have found and corrected most of the style issues that come with using Q&A out of the box with Genesis child themes but this one is still outstanding. In the single question and answer page area the QA User Box floats right and down to the bottom of the container. I've managed to extend it by adding a width element, but that won't fix the placement issue. See attached screenshot...

    Philip John

    Hiya,

    I'll ask a couple of the theme devs if they can chip in and provide some guidance here for ya!

    It'd be good if we could also see the CSS you've used so far and even better a link to the site where we could see this in action.

    Cheers!
    Phil

    Avi

    I'm in the same boat I think.

    The little box on the right that displays the gravatar and user name of the person who is asking the question seems to be pushed down towards to bottom. This doesn’t seem to be the case with that same box in the answers section.

    Here is an example of what I am referring to.

    http://www.jewsbychoice.org/dev/questions/how-long-is-pesach/

    Any ideas?

    Thanks

    Mason

    Hiya guys,

    The reason for this difference is that the Question has an extra div tag for the question content and the date stamp. This leads to the User Box being moved down a bit.

    The content in the answer doesn't have a div, paragraph tag, or date stamp so the User Box appears in-line with the content.

    I've already asked the plugin developer to have a look and see if we can handle this better in an update. We'll report back soon :)

    Thanks!

    scribu

    I'm thinking of making use of the $content_width variable that can be defined in themes.

    scotmacdonald
    • Elite
    • 60
    • #2,073

    @scribu any word on this one? I saw mention of an alpha release with another issue and wondered if this issue might also be addressed?

    scribu

    @scotmacdonald re user boxes: you have some weird CSS rules there, which are not part of the original stylesheet that comes with the plugin.

    Anyway, I've attached an alpha version that makes use of $content_width, if it's defined by your theme.

    @Avi: This alpha also contains a fix for the user box positioning problem you mentioned.

    scotmacdonald
    • Elite
    • 60
    • #2,073

    If they're weird it's only because that's what it took to make it work. Thanks for the update.

    scotmacdonald
    • Elite
    • 60
    • #2,073

    Update hasn't fixed the issue. See attached...

    Avi

    @scribu, thanks for making the updated version available. Unfortunatly I still seem to still be having the issue.

    Here is a link if you want to see how it is displaying.

    scotmacdonald
    • Elite
    • 60
    • #2,073

    Guys

    Can we envision a solution to this issue soon, or should we move on to a dedicated Q&A theme because it can't be used on a live site with this problem.

    scribu

    @scotmacdonald and @Avi:

    That's the expected behaviour: the user box is floated to the right, at the same height as the links on the left.

    scotmacdonald
    • Elite
    • 60
    • #2,073

    @scribu

    How can you say this is the expected behaviour when your own demo shows the user box atop the post and extending the full width of the content area as per the attachment?

    scribu

    The theme on wpmu.org has been customized to fit the design.

    Here's how it looks by default:

    scotmacdonald
    • Elite
    • 60
    • #2,073

    @scribu

    Well then once again a plugin that does not perform as advertised on this site.

    Great plugin, but poor execution, and hardly worthy of your other fine work.

Join 376705 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member