RSS Error: XML error: Reserved XML Name

Hello,
I've been getting some rss feed errors on my dash rss feeders.. this is the error "RSS Error: XML error: Reserved XML Name at line 2, column 38" any ideas? i cant seem to find any other threads relating to this?

    Andrew
    • Erstwhile founder
    • 7,430
    • #14

    Have you tried running the feeds through a validator to see if they have any issues?

    Thanks,
    Andrew

    drmike

    Can we also get a link please for the rss feed?

    mirozake
    • 0
    • #30,213

    just checked the validator... http://feedvalidator.org/check.cgi?url=http%3A%2F%2Falterplanet.com%2Ffeed

    "
    This feed does not validate.

    *

    line 1, column 1: Blank line before XML declaration [help]

    ^

    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.

    *

    line 62, column 28: guid should not be blank [help]

    <guid isPermaLink="false"></guid>

    Barry

    You have a blank line at the top of that feed. Have you edited any of the core files in WPMU or are you using a plugin to generate the feed?

    drmike

    Also please check to see if there are any empty spaces after the closing ?> or blank lines after that within wp-config.php

    mirozake
    • 0
    • #30,213

    actually, my wp-config.php has no closing ?>
    how strange, I've searched the whole document for it and cant find it. Any ideas what line it should be on?

    here is my wp-config.php file without the password, keys, and database name..

    <?php
    /**
     * The base configurations of the WordPress.
     *
     **************************************************************************
     * Do not try to create this file manually. Read the README.txt and run the
     * web installer.
     **************************************************************************
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '*********');
    
    /** MySQL database username */
    define('DB_USER', '***********');
    
    /** MySQL database password */
    define('DB_PASSWORD', '********');
    
    /** MySQL hostname */
    define('DB_HOST', '**********');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'alterplanet.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY', '************************************************');
    define('SECURE_AUTH_KEY', '**********************************');
    define('LOGGED_IN_KEY', '*********************************************');
    define('NONCE_KEY', '***************************************');
    define('AUTH_SALT', '************************************************');
    define('LOGGED_IN_SALT', '**************************************');
    define('SECURE_AUTH_SALT', '************************************');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable wp-content/sunrise.php support
    define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** WordPress absolute path to the Wordpress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    Andrew
    • Erstwhile founder
    • 7,430
    • #14

    It should be at the very end of the file.

    Thanks,
    Andrew

    mirozake
    • 0
    • #30,213

    Alright, its in. but I still continue to see the same error as before.

    You can read the error first person here, http://alterplanet.com/feed/

    so im going through alot of wpmu files ive never even opened, and I am finding alot of blank lines after ?>

    also wp-cron.php, and wp-config-sample.php has no ?> is this normal? im still looking for more as we speak..

    drmike

    They may have taken out the closing ?> mark. The Akismet plugin is like that and I seem to remember other files that need or could be edited going that route.

    I'd try renaming the plugins and mu-plugins subdirectories and see if that affects anything. If so, you know it's an issue with a plugin.

    Are you running any sort of caching?

    Andrew
    • Erstwhile founder
    • 7,430
    • #14

    Hiya,

    As previously mentioned, it looks like you have some empty space somewhere. Try removing all plugins to see if that resolves the issue. If so then you need to add the plugins back in one at a time until you find the one causing the problem.

    Thanks,
    Andrew

    mirozake
    • 0
    • #30,213

    no caching.. ill try removing my plugins now....

    mirozake
    • 0
    • #30,213

    yep,
    I renamed plugins and mu plugins, now my rss feeds function.. I've narrowed it down to my mu-plugins folder. so, now I'll have to reinstall the plugins one by one to figure this out. Kind of alot, so ill let you guys now the outcome when im done.

    drmike

    Glad you figured it out. I always thought it strange that a browser will take all the blank lines you can output when it comes to html but xml is such another story.

    One thing to watch: CPanel's file editor is notorious for putting in extra lines in files at the end of the file content. Something to check.

    mirozake
    • 0
    • #30,213

    I did find maybe 20-30 of the core mu files I've never touched with blank lines at the bottom.. There are still more i havn't taken out, and the problem is solved.. so i geuss some files are more tempermental than others when it comes to these blank lines

    drmike

    That's probably why the wp developers have started not using the ending ?> mark within files that are meant to be editable. Without that mark, you can have all the blank lines and spaces you want.

    I think it's sloppy coding though.

    If anyone ever wants a project to contribute to wp outside of the normal channels, a site that md5's each file individually and then per subdirectory would be useful. That's a quick check to see what file is different than the ones downloaded.

Join 366093 happy members

Get access to our entire collection of epic plugins, astonishing themes & genius support

Become a member