Dazed & Confuzed by Domain Mapping - Need a Little Help from My Friends

Hello - exciting to trial your plugins.

My goal is to use wpmu to create sell design/resold hosting/marketing services/domains.
I just ordered whmcs. I installed domain mapping to integrate with whmcs/enom.

Is it possible to create an order button in whmcs, and have my customer choose a domain name and package, then have whmcs create a new site in wordpress without custom development?

Also with domain mapping do I need multi-site?
How do I test domain mapping?

  • Rupok

    Hi Scott,

    Thanks for asking. Let me answer one by one.

    Is it possible to create an order button in whmcs, and have my customer choose a domain name and package, then have whmcs create a new site in wordpress without custom development?

    Well, WHMCS provisioning plugin mostly does that. For integrating WHMCS with Domain Mapping, you will need the WHMCS Provisioning plugin available free on GitHub.

    You should create a product in WHMCS and that should create a subsite on your multisite network. But I'm afraid, that won't map the newly purchased domain to that sub-site automatically. Your user will have to do the mapping part manually.

    Please note, WHMCS Provisioning is a legacy plugin. This means it is no longer actively developed or supported by WPMU DEV. To learn more about our retired legacy plugins click here.

    with domain mapping do I need multi-site?

    Yes. Domain Mapping plugin only works in WordPress Multisite because the main purpose of this plugin is to map custom domain names to sub-sites of a network. So a Multisite network is mandatory for using Domain Mapping.

    Please let us know if you have any confusion or any further query. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Rupok

    Hi Scott,

    Thanks for asking. I'm sorry but I'm not exactly clear about the problem. You said when the account is created, new.site.com is not resolved. Can you please explain a little more about this?

    If you have your wildcard DNS entry set up properly, then you should be able to access your subdomain subsites instantly. Is this not happening for you? In that case, can you please create a subsite manually and check if you can access that subsite dashboard instantly? If no, then I think, there is something missing in your multisite configuration.

    I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Please confirm here when you are done granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.