- I recently

Hello - I recently upgraded to the pro membership. I installed and activated the plugin and panel. I have a full multisite install up and running and has been without any issues. After activating the WPMU Dev plugin, I installed the Domain Mapping plugin and as soon as I went to activate it, I get the "too many redirects" on my page. What is going on? Now I cannot access anything on my network! Please advise. http://screencast-o-matic.com/screenshots/pp/VIj/1486950416142-74291.png

    James Morris

    Hello Justin,

    I hope you are well today.

    The simplest way to get your network back is to login to your server via FTP and navigate to wp-content/plugins/ and remove the domain-mapping plugin folder. Then, make sure your .htaccess file is restored to the default for multisite networks. It should look something like the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    Once you have done the above, you should be able to access your WP dashboard again.

    Next, we need to find out why your site was not working with Domain Mapping...

    In order to help you better with that issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

    James Morris

    Hello Justin,

    I apologize for the delay in responding here.

    The problem was with your configuration of Domain Mapping and Cloudflare. You seem to be running a shared SSL certificate on Cloudflare and forcing Admin SSL login via Domain Mapping. This does not seem to be compatible. I've reset your Domain Mapping Settings so that Force Admin SSL Login is disabled. You can now access your WordPress Dashboard.

    I'm going to ping our SLS Team (code experts) to get their valuable feedback on this issue to see if we can determine the exact cause of why Domain Mapping kept going into the redirect loop. But, I suspect it's related to the use of the shared Cloudflare SSL certificate.

    Best regards,

    James Morris

    Mahlamusa

    Hello Justin,

    I hope you are doing great today. I was wondering if you still need help with this as I have noticed that you were yet to receive a response from us, however I have noticed that your website is accessible without the redirect issue.

    Please confirm if you are still having any issues with the Domain Mapping plugin or not, we are always happy to assist you resolve this issue.

    I hope you enjoy the rest of your day.

    Cheers,
    Mahlamusa