"0 pages cached" even though all caching options are turned on

Hello,

The attached photo shows Hummingbird listing us at 0/42 pages cached.

However, I think we've turned on every type of caching that is available from this plug in. How do I get it to cache the 42 pages?

I've also granted support access if you needed to go in to take a look.

Thanks!

  • Adam Czajczyk

    Hello Jenny

    I hope you're well today and thank you for your question!

    I checked your site and there's no need to change settings, it's configured fine. The point is that the cache is not "automatically built for entire site" - once it's enabled it's only created for each of the pages once that page is visited for the first time. As a result it might take time to generate it. Some pages - if not visited - might even stick "un-cached" for quite a long time.

    Additionally, there's an option enabled in Page Cache settings to clear full cache so whenever there's any post added, all the cache is deleted. That said, you could try two things to "speed up" cache generation:

    1. You can try to disable that "clear full cache when a post/page is updated" option but you need to see if updates will be visible instantly on site after that; on some setups that needs to be enabled otherwise updates to the post are not visible until cache is cleared.

    2. Whenever you see there's 0 or just a few pages cached, you can actually crawl the site (I did it already this time) e.g. with this tool:

    http://tools.seochat.com/tools/online-crawl-google-sitemap-generator/

    Simply put your site's address in the form there and use "Check" button then wait until crawl ends, no need to download anything from there. It will visit up to 100 pages on your site so it will trigger "automatic" cache generation.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.