1) on activating 'admins adds' plugin: Notice: has_cap was

Hi

1) on activating 'admins adds' plugin:

Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /public_html/wp-includes/functions.php on line 2925

The plugin generated 133 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

2)Activating 'Admin message' plugin produces:
Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in
public_html/wp-includes/functions.php on line 2925

3)Ativating 'bp-group-calendar' produces: Fatal error: Class 'BP_Group_Extension' not found in public_html/wp-content/plugins/bp-group-calendar/groupcalendar/bp-group-calendar.php on line 103

Buddypress installed &
Only wpmudev plugins installed

Thanks
Paul