1 service with 2 different time slots

Ok i read thru few of the forums but couldnt get how to setup 1 service with different time slots - This is what I need. Only 1 appointment per time slot.
Days:Monday - Saturday
Time Slots: 7:30am, 9am-11am, 12pm-2pm

This is how I have my working hours setup: http://nikalabs.info/Screenshot.png

I have 1 service setup with 120 min duration.

Here is what I have: http://www.nikalabs.info/genesis/online-appointment/

Not sure why my 9 to 12PMs are empty?

  • Tyler Postle
    • CGO

    Hey Ali,

    Hope you are doing well today and welcome to the WPMU DEV Community!

    This is happening because you have breaks set for 11am-12PM and since your appointment time is 120minutes(2 hours) your last possible appointment before your break is 9pm. So everything after that is blank until 12pm when your break ends :slight_smile:

    In your general settings at the bottom of the page Appointments > Settings > General Tab. There is an overwork break hours option, so you can have appointments overlap your break. Or if you want to turn the breaks off then as seen in your working hours screenshot, you can select 'No' for all the times on that right column.

    Hope this helps. Let me know if you have any further questions here!

    Cheers,
    Tyler

  • Ali
    • Site Builder, Child of Zeus

    Thanks for the quick response Tyler!
    First issue solved / now as mentioned above this is how I want the the slot will be available:
    Time Slots: 7:30am, 9am-11am, 12pm-2pm

    The beginnings for these time slots can be only 7:30AM , 9AM and 12PM

    Is this possible?

  • Tyler Postle
    • CGO

    Hey Ali,

    Thanks for granting that access.

    You will need to use a dummy provider for this. Because you have 2hour time slots except that 730 one which would overlap your 9 o'clock one.

    So, if we use a dummy provider, which is essentially a fake WordPress user that is actually you. Then we can set that users times to ONLY work that 730 appointment. and have your main user work the other two.

    Then in the General settings in the "Accessibility settings" we will assign dummy providers to your main user. This way all their appointment emails get redirected to you, since it's actually you anyway :slight_smile:

    Might sound a bit confusing, but this is actually what the dummy provider feature was added for.

    So,

    1. Create a new user

    2. Select it as a service provider, attach it to the service and check the "Dummy" box

    3. Go to General settings and assign dummy providers to your main user

    4. Set the dummy's service times only for the 730 appointment window

    5. you should be good to go!

    Let me know if this does the trick :slight_smile:

    All the best,
    Tyler

  • Ali
    • Site Builder, Child of Zeus

    The thing is I don't how and why they are turned off - I granted access support for someone to look at this but not sure why appointments are off now. This is a staging (test) site so you can change it however.

    Thanks!!

  • Michelle Shull
    • DEV MAN’s Apprentice

    Okay! I think I've got you up and running. Here's what I did:

    1. To get the schedule filled with blocks again, the No Specific Provider hours had been set to no each work day, so I turned them back on per your description of how you want things to go here. (http://www.nikalabs.info/genesis/online-appointment/?wcalendar=1409516502#app_schedule)
    2. On the General Settings tab, allllllll the way at the bottom, you had settings turned on which allowed overwork for both breaks and the end of the day. I turned those both to no, and that should fix it.

    Except, it seems that you're making changes to your site right now? The changes I've made have been undone while I was typing this.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.