30 Minute Break Times in Appointment+ Plugin

Checked this thread: https://premium.wpmudev.org/forums/topic/option-for-30-minute-appointment-slots-with-30-minute-breaks-between

But it didn't solve my issue. Basically I need the appoints to work from 9am til 12pm then have a 30 minute break, go from 12:30pm until 2:30pm and then another half an hour break (pick kids up from school) then go from 3pm until 5pm.

How would I be able to achieve this?

I've set the multiple break times to be as above and our standard session times go for 60 minutes under Settings -> General

Your help is appreciated, Cheers Mick

  • pxwm
    • WP Core Meltdown

    Hi @PC - I hope you don't mind me chiming in

    Hi @Mick

    I would appreciate if you could confirm the following:-

    Are you using v1.3.1?
    If you are have you Activated the 'Durations' add-on in the 'Add-ons' tab?
    If so have you set the 'Time slot calculus method' to 'Minimum time based appointment duration calculus (legacy)' in the 'General' tab

    If you have completed the above then I would suggest you revise the following:-

    In the 'Working Hours' tab:-

    From the dropdown select the 'no specific provider' and set all the 'Work?' fields to 'No'
    Then select each Service Provider from the dropdown in turn and set the Working Hours as required.
    Then set the Break times
    Then Save

    Hope this helps
    Regards
    SteveB

  • Mick Davies
    • New Recruit

    hey guys,

    yes 1.3.1
    Durations installed
    Set Time slot Calculus method to min time based (legacy)

    Tried setting the default to all days to "No" and added my client in as a service provider - same issue occured on front end (caching is also not turned on)

    - Removed client and set the default days back up - same issue again

    It seems you simply cannot take breaks for half an hour when your service duration is 60 minutes. Any further help would be greatly appreciated including how to remove added break times -> there is a add button but no remove button.

  • pxwm
    • WP Core Meltdown

    Hi @Mick

    Could you please set the 'Time Base' to 30mins in the 'General' tab
    Then Save

    This should then allow you to set the break times.

    However suggest you will have to revise the following in the 'Working Hours' tab:-

    From the dropdown select the 'no specific provider' and set all the 'Work?' fields to 'No'
    Then select each Service Provider from the dropdown in turn and set the Working Hours as required.
    Then set the Break times
    Then Save

    Please Note: Setting the 'Time Base' to 30mins will mean appointments can be made on the Hour and Half Hour.

    Hope this helps
    Regards
    SteveB

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.