301 Error uploading snapshot to Amazon S3

Howdy,
When I tested the Amazon S3 connection and did a trial backup.
I get the following error
ERROR: Error: Send file failed :301 :
Any help would be great.
Cheers,
D

  • Vaughan
    • Support/SLS MockingJay

    hiya

    thanks for posting.

    are you sure you entered the correct url for that bucket?

    amazon error code reports.

    The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.

    hope this helps.

    thanks.

  • dunskii
    • Site Builder, Child of Zeus

    I dont see where I would enter a url.
    I had a directory name but removed that to reset the default in case that was the problem, without any luck.

    Heres the test configuration message
    Connecting to AWS
    Using SSL: Yes
    Setting Region: US Standard (s3.amazonaws.com)
    Using Storage: Standard
    Using ACL: private
    Sending file to: Bucket: #######: Directory: Error: Send file failed :301 :

  • Paul
    • The Green Incsub

    @dunskii

    https://dl.dropboxusercontent.com/u/2616987/WPMUDev/aws_sdk_compatibility_test.zip

    Please download the following file. Unzip it on your local PC. This should create a directory named '_compatibility_test'. You need to FTP that directory and all the content files to your site so that it is off the site root. Once uploaded you can then open a browser and check the AWS compatibility. The URL you need to browse to is http://www.somesite.com/_compatibility_test/sdk_compatibility_test.php where 'www.somesite.com' is your actual website domain.

    Do you know if your hosting has OpenSSL or some SSL configuration enabled? This is not the same as you having an SSL certification for your hosting. This is so your host can open a secure connection to a remote host. You might want to ask your host provide about this.

  • dunskii
    • Site Builder, Child of Zeus

    I'm based in Sydney and most clients and their customers are based in Oz so thought it best to have it as close to my server (Pyrmont) as possible.

    Though for testing purposes I selected us standard as the Sydney option wasn't available.

    My server has OpenSSL available

    I ran that script and get the happy message
    Bottom Line: Yes, you can!
    Your PHP environment is ready to go, and can take advantage of all possible features!

  • dunskii
    • Site Builder, Child of Zeus

    I've tested this with backup buddy and the upload works fine. So I am assuming that it has something to do with snapshot.

    If possible I would like to move across to using this as backup buddy is in a perpetual state of beta when it come to multisite.

    So any foresight into this would be great.

    D

  • Paul
    • The Green Incsub

    @dunskii,

    Sorry for the delay. I'm assuming you are still having the same issues??

    So refreshing my knowledge on your issue. You are getting the 301 on the destination testing. But have you tried to actually run a snapshot archive and have it sent to AWS? Just wondering if that might be somehow working.

    Let me know.

  • dunskii
    • Site Builder, Child of Zeus

    Hi Paul,

    Don't worry about the delay.

    As this is something that i'm sort of doing live beta testing on, since backup buddy isn't scheduled to run until myself and most of oz should be asleep. I've tried a whole heap of different things to get it working.

    I do know that snapshot and backup buddy don't play nice together, so to run one I need to disable the other. I tried unistalled bb all together to see if that would help, but I get the same issue.

    Considering a good chunk of the plugins on my network are from WPMUdev I already put a lot of trust in you company so if you want to have a look on the dark side, I'm comfortable with that.

  • Paul
    • The Green Incsub

    @dunskii,

    Strange I had not know of a conflict between Snapshot and BackupBuddy. Wonder where the conflict is. Probably using some of the same AWS and Dropbox libraries.

    Considering a good chunk of the plugins on my network are from WPMUdev I already put a lot of trust in you company so if you want to have a look on the dark side, I'm comfortable with that.

    That would be great. Just need an FTP account that give me access to the snapshot plugin folder so I can add in some debug output to possibly see what is going on. And of course access to wp-admin in order to run Snapshot.

    Send account info to

    paul [at] incsub.com

  • Paul
    • The Green Incsub

    @dunskii,,

    Finally getting to this as of this afternoon. Strange things is I setup a new destination using my own AWS S# credentials and a new snapshot backup for just DB tables and the file was uploaded just fine.

    But yeah on your own destinations I'm seeing the 301 error when testing the bucket. A mystery still. Hope I can get to the bottom of this.

    Thanks for your patience.

    Paul

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.