3d day without results… Need help with Multi-DB

Hello,

The first error was when launching file move-blogs.php

Houston, we have a problem!

Looks like you need to create your new db’s! If you’re lucky, this link still works – click me

Database Error: Access denied for user ‘mmmru_superadmin’@’localhost’ to database ‘mmmru_global’

I solved this error by creating manually database mmmru_global and manually added user to this database. This error disappeared.

Then when clicking: “To start the copy process click here”

I get these error messages:

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmru/public_html/wp-content/scripts/move-blogs.php on line 124

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmru/public_html/wp-content/scripts/move-blogs.php on line 125

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmru/public_html/wp-content/scripts/move-blogs.php on line 140

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmru/public_html/wp-content/scripts/move-blogs.php on line 141

Guys I’m not new in installing scripts or plugins but 3 days for this problem it is huge.

Please help me to solve it totally.

  • Barry
    • DEV MAN’s Mascot

    I solved this error by creating manually database mmmru_global and manually added user to this database. This error disappeared.

    Can you confirm that you’ve created all the databases you need for your multi-db installation, created the user account in mysql for it, added the permissions for that user to all the newly created databases?

    You then need to edit move-blogs.php and enter the database prefix and user account details in the placeholder locations at the top of the file and *then* run it.

    The line (quoted above) suggests that you haven’t created the databases.

  • nickbnn
    • WPMU DEV Initiate

    Hello Barry,

    Thank you for quick answer and sorry for not responding faster.

    The point is that I needed 4096 databases for the proper work of my multiuser blogging project. And the hosters didn’t give me root access for proper work, that is why I had to change hosting provider and now I have hosting withh all requirements that I need. And I past though the installation of

    Mullti-DB plugin on this new hosting.

    In reply to your question, yes I confirm that created 4096 datbases and one global database, and yes I created the user account and added this user to all databases with required permissions.

    Than we have made all necessary actions with move-blogs.php file and launched it

    This time we are getting these errors:

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmadmin/public_html/wp-content/script/move-blogs.php on line 140

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/mmmadmin/public_html/wp-content/script/move-blogs.php on line 141

    I get these errors after click on step 4: “To start the copy process click here”

    This is the link you can see everything yourself:

    http://mmm.ru/wp-content/script/move-blogs.php?table=copy

    Please help me to find solution to solve this issue as soon as possible.

    Eagerly waiting for your reply.

    Kind regards,

    Nick

  • Mark de Scande
    • Syntax Hero

    @Barry I think it is time you give this script a work out i also had this err and every thing was 100% i have seen this err on about 3 posts on the forums yes i know we should @mustafa never mind warnings I guess you set it succesfully. but think of if it like this customer just paid big bucks and now he goes trough all the steps and he gets a err and yes if he just had a look around at the forums he would have picked up don’t stress about the err …

    @nickbnn Buddy i feel your pain i had the same problem and i then added a new blog and it started filling up the new tables if you go here http://mmm.ru/wp-content/script/move-blogs.php you will see that there is no err

    @nickbnn Welcome i see it is one of your first posts the guys here are always help full and trust me your on the right track to take your website to the next level http://mmm.ru/

    Thx

    Mark

  • nickbnn
    • WPMU DEV Initiate

    Hello Mustafa,

    Thank you for your answer, but after creation of new test blog I got this message:

    http://test.mmm.ru/

    And I cannot find any md5 tool… Can you please explain where to find it aand what it will do for me?

    P.S. I spend more than a week trying to solve it. I even changed hosting provider with which I were hosted my sites about 4 years… I need to find a solution…

    Eagerly waiting for your reply.

    Kind regards,

    Nick

  • nickbnn
    • WPMU DEV Initiate

    Thank you, Mark,

    I have added other new blogs and error message the same.

    test.mmm.ru

    test2.mmm.ru

    So I do not know what to do…

    I spend the week without any result.

    @Barry I really need your help with it.

    Eagerly waiting for your reply.

    Kind regards,

    Nick

  • Mark de Scande
    • Syntax Hero

    @nickbnn Dont for get i am not a coder :slight_smile: I am just a user like you

    Please have a look at your set up

    1) Cpanel Subdomains (Screen Shot) Make sure that star is there *

    2) Ask your host if he has added a * Wild Card to your dns Settings

    3) I have tested it here and all look fine http://dnscheck.pingdom.com/?domain=mmm.ru

    4) wp-config remember make sure all details are correct (ps i have left my old db details in there)

    5) db.php rename it and see if you can add a new blog if you have not change your wp-config and you still can not make a new domain then you need to start over remember when your running of the old DB you should be able to add and new sites/blogs with out any problems if you cant that means your Wild Card DNS setting are not set up ..

    I know this is not the answer your looking for but some time to start over is the best idea :slight_smile:

  • nickbnn
    • WPMU DEV Initiate

    @mark de Scande

    Hello my friend :slight_smile:

    For me personaly its a real pleasure that the same user like me (not product owner or support) really wants to help to get this plugin working.

    I am surprised that for the price which product owners are charging every month the level of support isn't corresponding to the price that is being charged.

    Though I am happy to pay this price foor the package of plugins and themes, I am doing it because I love the products inside the package. But I take the first product from this package and for over a week I cannot make its features work properly. And my motivation to be a member of this community was inspired by the promise that everything works perfectly well.

    I am the owner of bloggers community with more than 84000 users – FreeTrafficSystem.com and I do understand the importance of proper and timely support for the success of the business.

    I have prepaired screenshots which are showing that we did everything like suggested in the installation guide.

    Thank you one more time and waiting for the support from plugin creator :slight_smile:

    Kind regards,

    Nick

  • Mark de Scande
    • Syntax Hero

    @nickbnn Thank you ..

    I had a look at the screen shots the first one looks 100% the rest of the DB stuff i have no idea

    Send the guys a email https://premium.wpmudev.org/contact/ just use the form include a link to this posts as well and ask them it they will log in to your server and have a look.

    Just some ideas i have .

    Do you still have your old DB ? if yes try to remove the Multi DB just remove the files and then see if your WP still loads up and see if you can add new blogs with out a problem if yes then try to add Multi DB back ..

    If you want you can set the domain up on BlogLines.co.za but i would need to know what you will do with all the sites if you want send me a email admin@bloglines.co.za

  • LCDist
    • The Incredible Code Injector

    Hey Nickbn

    I may be mistaken here as I also am not a coder or an expert by any stretch of the imagination…. but you have a global table for domain mapping…. which if I recall having domain mapping means you have a dedicated IP… again I may be thinking of a different plugin.

    But if you do have a dedicated IP… have you tried using your IP in place of ‘localhost’ in both the add_db_server( section as well as

    // EX: add_dc_ip(‘123.123.123.’, ‘dc1’:wink:;

    Note that if you do add the IP there is only 3 numbers dont add the 4th for that part.

    I know that worked with mine, my problem is the problogs working with multidb lol but I believe thats a completely separate issue.

  • DavidM
    • DEV MAN’s Mascot

    Hi Nick,

    I’m taking a look into this and have pinged Barry as well in case he might notice something I’m missing.

    Really though, it sounds like the issue you’re experiencing totally precedes Multi-DB. Can you please deactivate Multi-DB and be sure you can create sites without it first off?

    Thanks,

    David

  • nickbnn
    • WPMU DEV Initiate

    Thank you Mark and great thanks everybody for reply.

    Have been bussy solving this issue myself. My programmer helped me out.

    P.S. Very sad this wasn’t done by the support team of the community.

    P.P.S. Starting from the today will check other products of the community :slight_smile:

    Kind regards,

    Nick

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.