404 error on new sites created in multisite, fresh install.

Here we go:

This is the second time I’ve tried to install a WP multisite. First time on hostgator, this time on a vps.

Both times I’ve followed the instructions to the last line. It installes correctly, and I can create sites. However, when I try to reach them by clicking on the dashboard I get a page not found. I’ve searched a lot on this topic, and found a lot of different answers.

The most common problem seems to be the wildcard DNS thing. I’ve added a * in the subdomain section in cPanel, I’ve edited the DNS zone pointing the wildcard to my IP in a lot of different ways. Nothing is working.

I’ve edited the wp-config and the .htaccess as instructed.

I really dont know what to do. Does any one have a clue what might be going on? Why I’ve failed twice?

The only thing I’ve not tried yet that came up in my searches is editing the https.conf file. Whatever that is. It sounds really scary, and I cant find it either.

Forever grateful for someone that can help me.