404 Error When Trying to Create a Group

Hello,

I have tried everything I could find on the internet to solve this
problem. I am getting a 404 error on the following page:
groups/create/step/group-avatar/. The group is created, I can visit
other pages (although I haven’t tried everything out yet), but the
group-avatar page is keeps getting this error.

I am running my site on nginx and amazon ec2 (ubuntu 10.04).

I searched Google and found various posts which talk about the proper
rewrite rules for nginx and have tried them all – none of them have
helped [I've tried various ones on this forum, on wpmudev.org and
other sites/forums].

As such, I am stuck. I would love it if someone could help me figure
out what is wrong.

Here is the URL to the site [please note that this is just a test
site which I am trying to set up to work on a clients project]:
http://howtowrite.net.

And here is my nginx configuration:

server
{
listen 80;
server_name howtowrite.net *.howtowrite.net;
access_log [PATHTO]/log/access.log;
error_log [PATHTO]/log/error.log;
# rewrite rule – files
location / {
root [PATHTO]/howtowrite.net/public;
index index.php;

gzip on;
gzip_http_version 1.0;
gzip_vary on;
gzip_comp_level 3;
gzip_proxied any;
gzip_types text/plain text/css application/json
application/x-javascript text/xml application/xml application/xml+rss
text/javascript;
gzip_buffers 16 8k;

if (!-e $request_filename) {
rewrite ^.+/?(/ms-.*) $1 last;
rewrite ^/files/(.+) /wp-includes/ms-files.php?file=$1 last;
rewrite ^.+/?(/wp-.*) $1 last;
rewrite ^.+/?(/.*.php)$ $1 last;
rewrite ^(.+)$ /index.php?q=$1 last;
expires 10d;
break;

}
}

location ~*
^.+.(html|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js)$
{
root [PATHTO]/howtowrite.net/public;
rewrite
^/.*(/wp-.*/.*.(html|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js))$
$1 last;
rewrite
^.*/files/(.*(html|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js))$
/wp-includes/ms-files.php?file$
if (!-e $request_filename) {
rewrite ^.+/?(/wp-.*) $1 last;
rewrite ^.+/?(/.*.php)$ $1 last;
rewrite ^(.+)$ /index.php?q=$1 last;
}

expires 30d;
break;
}
# php requests – fast cgi
location ~ .php$
{
fastcgi_pass 127.0.0.1:9000;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME
[PATHTO]/howtowrite.net/public$fastcgi_script_name;
include [PATHTO]/fastcgi_params;
}
}

Thanks and be well,

Moshe