500 Error on Frontend

Hi,

When I install/activate the WHMCS WP integration plugin it crashes the frontend of Wordpress but the Admin side continues working. As soon as I disable the plugin frontend comes back online.

I'm running a dedicated box with ubuntu 16, nginx, PHP7-FPM and SSL

The nginx logs are showing the following error: (domains & ip have been stripped for security)

[error] 29399#29399: *1408 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Cannot use object of type WP_Error as array in /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php:675
Stack trace:
#0 /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php(716): WHMCS_Wordpress_Integration->redirect_request('', '')
#1 /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php(1051): WHMCS_Wordpress_Integration->load_whmcs_url('')
#2 /wp-includes/plugin.php(601): WHMCS_Wordpress_Integration->on_parse_request(Object(WP))
#3 /wp-includes/class-wp.php(385): do_action_ref_array('parse_request', Array)
#4 /wp-includes/class-wp.php(724): WP->parse_request('')
#5 /wp-includes/functions.php(952): WP->main('')
#6" while reading response header from upstream, client: 51.171.181.40, server: _, request: "GET /wp-content/plugins/whmcs-wordpress-integration/includes/css/whmcs-six.css?ver=1.4.3 HTTP/2.0", upstream: "fastcgi://unix:disappointed:var/run/www.sock:", host: "MYDOMAIN.com", referrer: "https://MYDOMAIN.com/wp-admin/network/admin.php?page=wpmudev-plugins"
2016/07/11 20:54:24 [error] 29399#29399: *1529 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Cannot use object of type WP_Error as array in /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php:675
Stack trace:
#0 /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php(716): WHMCS_Wordpress_Integration->redirect_request('', '')
#1 /wp-content/plugins/whmcs-wordpress-integration/includes/class-whmcs-wordpress-integration.php(1051): WHMCS_Wordpress_Integration->load_whmcs_url('')
#2 /wp-includes/plugin.php(601): WHMCS_Wordpress_Integration->on_parse_request(Object(WP))
#3 /wp-includes/class-wp.php(385): do_action_ref_array('parse_request', Array)
#4 /wp-includes/class-wp.php(724): WP->parse_request('')
#5 /wp-includes/functions.php(952): WP->main('')
#6" while reading response header from upstream, client: 104.236.50.140, server: _, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:disappointed:var/run/www.sock:", host: "MYDOMAIN.com"