500 internal Error lost all the mappings

Server crashed, and the host made the following changes:

The reason the server load went so high was it was running suphp, this does not limit the amount of php threads per user/account.
I am upgrading to easyapache 4, and after the upgrade I'll bench the server to see how it handles a large amount of connections.

Once done the website is throwing 500 internal error, could notice the following error in the cPanel logs:
[pid 46074] [client 182.69.230.124:49575] /home/wwwxxxx/public_html/.htaccess: Invalid command '\xef\xbb\xbfsuPHP_ConfigPath', perhaps misspelled or defined by a module not included in the server configuration

If I remove htaccess, the site loads, but my mapped domains obviously don't work.

  • Nithin

    Hello Gary,

    I gave a closer look, and it seems to be an issue related to the configuration done by your host. I have commented out the following line in your .htacess file:
    #suPHP_ConfigPath /home/wwwsanlambewellc

    And now your website is loading fine, however I could notice that all the configuration made in your website related to domain mapping is lost as shown in the below screenshot.

    The changes made in the plugin is saved in the database, so it's odd that the mappings are empty in your website now. Would recommend you to get in touch with your host to fix the issue related to .htaccess file, and once done, we'll give a closer look to see whether there is any way to restore the mapped settings, if that isn't possible, you'll have to map the domains again manually to see whether it works fine, or not.

    Please do let us know what your host has to say about this issue. Have a nice day ahead. :slight_smile:

    Best Regards,
    Nithin