500 Internal Server Error when installing plugins

Any attempt to install a plugin using "WPMU DEV -> Plugins" results in "500 Internal Server Error" message returned by WPMU DEV Dashboard (red bar on top of the screen). This started with Hummingbird but also applies to other plugins.

  • Nithin
    • Support Wizard

    Hey Manfredi,

    Hope you are doing good today. :slight_smile:

    I checked your website, and it seems like you are using WordPress 4.3? It's odd that I don't see any notification in your dashboard to update to the latest version of WordPress 4.7.3. Have you disabled updates?

    I have noticed 500 internal server error common with old versions of WordPress, could you please update WordPress to it's latest version ie v4.7.3, it should work fine once you have updated to the latest version.

    Please do let us know how that goes, so that we could give a closer look, if needed. Have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Manfredi
    • WPMU DEV Initiate

    Thank you, so just need to update the version?I don't know sorry, how I can do this because we had several problems with this website especially plugins and actually admin.ajax-php affect website and load, how to do a backup in case to be sure to not lost all our database and website

  • Nithin
    • Support Wizard

    Hey Manfredi,

    so just need to update the version? because we had several problems with this website especially plugins and actually admin.ajax-php affect website and load

    Yes, I'm pretty such that this is the case, because the issue is only when we try to install WPMU DEV plugins, and I was able to install plugins via the official WordPress repository without any issues.

    I have seen such similar issues, and updating WordPress have helped in such cases, this would also give us a better idea whether the update would solve the admin-ajax.php issues too, or not.

    how to do a backup in case to be sure to not lost all our database and website

    Could you please check whether you can install Snapshot manually, ie through FTP. If yes, you could use Snapshot for backups.
    https://premium.wpmudev.org/project/snapshot/

    If that doesn't work, you can check whether your host offers any backup options. If not, please try the following plugin:
    https://wordpress.org/plugins/duplicator/

    Update: Seems like you are in Trial, so I'm afraid you cannot download the plugin manually via FTP. Please try the Duplicator plugin.

    I hope this helps. Please let us know how that goes, have a nice day. :slight_smile:

    Best Regards,
    Nithin

  • Rupok
    • Support Ninja

    Hi Manfredi,

    Thanks for asking. Taking backup with the Duplicator plugin is not very complex. Can you please go through this article to know how you can create a complete backup with Duplicator? https://www.elegantthemes.com/blog/tips-tricks/duplicator-an-easy-way-to-back-up-copy-or-clone-your-wordpress-content

    This article described all the steps needed to be taken nicely with screenshots. So I believe, this will help.

    If you still have any confusion after going through this article, please let us know. We will be glad to help further.

    Have a nice day. Cheers!
    Rupok

  • Nastia
    • Support Rock Star

    Hello Manfredi , hope you're doing well!

    Since the automatic One-click WordPress update for some reason is not working on your sandbox site, please try to update the WordPress manually.

    Download a fresh copy of WordPress here:
    https://wordpress.org/download/

    Extract the zip archive. Inside the zip archive, you will find a folder named wordpress.

    Using File Manager at yourcPanel, access the /publich-html/dev/ folder, where the development copy of your site is located.

    Upload the wp-includes and wp-admin folders to /publich-html/dev/ replacing thr old onse. Upload all new loose files from the root wordpress directory of the new version to your existing /publich-html/dev/ root directory.

    DO NOT delete your existing wp-content folder and wp-config.php file.

    Let us know if you have any further questions or if you need any assistance.

    Kind regards,
    Nastia

  • Nastia
    • Support Rock Star

    Hello Manfredi ,

    Hope you're doing well!

    We received your follow back via email.

    Would you please send to us your credentials and so we could update the WordPress on your site

    You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    Waiting for your reply!

    Kind regards,
    Nastia

  • Nastia
    • Support Rock Star

    Hello Manfredi , hope you are doing well!

    I've manually updated the WordPress version from 4.3 to 4.7.4 on the development copy of your site. The update went well and caused no issues.

    Before moving your site back to live, please make sure that the dev's site appearance is the same as at your current live site. On the development copy of your site, the logo is missing and the menu is not assigned.

    You've mentioned in chat that there were errors on the site. Would you please let me know more about these errors? What are the errors and where they are shown?

    Please advise,

    Kind regards,
    Nastia

  • Manfredi
    • WPMU DEV Initiate

    Hi Nastia,

    thanks but I mentioned there are many errors on dev site if you look into now, for example the menu is different and also logo , same thing for infinite scroll in the categories and widget with descriptions are not working, and products are different from the live site, same thing from the button looking for buy now , pre-order, also conversion currency it's not available

    how to solve this things?

    Best,
    Manfredi

  • Manfredi
    • WPMU DEV Initiate

    Hi, nobody follow up this thread?

    thanks but I mentioned there are many errors on dev site if you look into now, for example the menu is different and also logo , same thing for infinite scroll in the categories and widget with descriptions are not working, and products are different from the live site, same thing from the button looking for buy now , pre-order, also conversion currency it's not available

    how to solve this things?

    someone could use duplicator or work on dev site? before to be live on original site

    as wordpress version is not updated and website have slow problems, php need to be updated to version 7.0, also plugin table rates shipping, pre-order and product enquiries need to be updated

    Best,
    Manfredi

  • Sohag Ronjon Dey
    • Support

    Hi Manfredi,

    Thanks for contacting and I hope you are having a beautiful day! :slight_smile:

    I have updated the menu and logo in the dev site. I have also fixed the scrolling and description widget in the category pages. I have imported the products and widgets. I have also fixed the style of buy now, pre order button.

    Please check the site and let us know your comment. Please also let us know if you need any further help.

    Cheers,
    Sohag

  • Manfredi
    • WPMU DEV Initiate

    Hi Sohag,

    thanks it's seems better will check properly, but the images didn' t open properly (screenshot attached), and also can we update all the products with the new ones (please look here the difference) in the website?

  • Sohag Ronjon Dey
    • Support

    Hi Manfredi,

    Hope you are doing well today! :slight_smile:

    The product images are showing now. The CDN Linker plugin was conflicting with the image urls.
    Please check the update. I am trying to bring the product data to the dev site. I will update you about it.

    Cheers,
    Sohag

  • Manfredi
    • WPMU DEV Initiate

    Thanks again the images are showing now, They told me also some plugins need to be updated like (Table rate shipping, pre-orders and product enquiries) same thing for php version should updated to 7.0.

    Let me know if we forget something else. Thx

  • Manfredi
    • WPMU DEV Initiate

    Hi , sorry for my severals msg :slight_smile: I tried to access wp.dev.manfredistyle.com/wp-admin

    and here the screenshots

    please check is is working for braintree (gateway credit card plugin) and other updates for plugins as written before and php version 7.0.

  • Manfredi
    • WPMU DEV Initiate

    I tried to a test to buy a product and is not adding to the cart. and dev.site is very slow :slight_frown:

    anyway before all to do the action to change to dev to live site even if all seems repaired. please wait our confirmation.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.