504 gateway time-out when trying to run a Snapshot

Any time I try to run a Snapshot on my site it gets stuck and I’m getting a 504 GATEWAY TIME-OUT error.

I also see two back up .zip files showing in managed backups in snapshot with today's date, but I haven’t created them and I have no managed backup scheduled on the site.

  • Predrag Dubajic

    Hi Stacy,

    Hope you're doing well.

    504 error is usually related to execution time being reached and on your site the value is set to only 30 seconds and Snapshot suggests to have this at least 150.

    I tried changing this from your .htaccess file but your server doesn't allow this change to be made that way and when I check your site PHP info it still shows that the execution time master value is set to 30 seconds.

    Can you get in touch with your hosting provider, ask them to increase your maximum execution time to 150 seconds (or 300 if possible) and then give it another try?

    I also see two back up .zip files showing in managed backups in snapshot with today's date, but I haven’t created them and I have no managed backup scheduled on the site.

    Hmm, these seem manually started backups, did you had any from before or this is the first time it happened?

    Best regards,
    Predrag

  • Stacy

    Also of note - I was on chat with an awesome support person that was able to get the backup to at least partially run yesterday. Every time I have tried through the network admin dashboard I only got to 1% after at least 20 minutes of having the tab open trying to run the backup. It was the support access person that actually got to the timeout error, not me.
    ***stating that because... I have updated the max_execution_time to 300 as requested, and as I am trying to run the backup I still cannot get past the 0% spinning circle***

  • Predrag Dubajic

    Hi Stacy,

    Yesterday the master value was showing 30 seconds but I can see now that it's set to 300, so that part is ok now, however I'm still getting an error during the backup.

    After some extensive testing I was able to create a backup of the themes by excluding Upfront from that snapshot, but when doing a DB, media and theme backup (with Upfront excluded) it failed again.

    So the backup part is actually working fine, but the issue is that some limit on the server is reached and it fails.
    Upfront is a complex system so it has a lot of files and that was probably the cause when I was trying the theme backup.
    And with DB, media and theme backup there's again a lot of files to process, regardless that the Upfront is excluded and it hits that limit again.

    Could you ask your host to check the server logs as that should give us more information on which limit was reached during the backup process?

    Best regards,
    Predrag

    • Adam Czajczyk

      Hi MSAMike

      I hope you're well today!

      The most recent support tickets of yours regarding Snapshot are quite old already and as I see they were related to different issues. I understand then that you have contacted us via a live chat mostly?

      If so, please note that our colleagues assisting you during support live chat are a bit limited in what they can do/try and time they can spent on it - and troubleshooting backup issues is often very time consuming.

      Furthermore, even though the "end error" is the same (504 in this case) the reason for it doesn't necessarily have to be the same. And often is not :slight_smile:

      That being said, could you please start a separate ticket of your own regarding this on our support forum (instead of live chat)? Make sure, please, that you have also enable support access to the site in question and we'll do what's possible to deal with the issue for you.

      Best regards,
      Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.