A+ Appointments lower limit setting doesn't seem to work

My question is about Appointments+. Does this setting [Appointments lower limit (hours)] only work when Auto Confirm is set to No?

There's an "Appointment lower limit (hours)" setting in A+. According to this post by Jose https://premium.wpmudev.org/forums/topic/appointment-lower-limit-not-working-as-expected#post-860937 it should be blocking booking if "current time + appointment length" (so the appointment end time) is less than hours set in the option.

How do I get it to work?