Getting "Members Only" notice when program is configured correctly as far as I can tell

A client purchased a membership, but keeps getting my "Members OnlyThe content you are trying to access is only available to members. Sorry. Welcome, members!" page. I cannot view the pages with my test account either. This happens even when logged in as admin.
I granted access and left username/password in the notes section.

  • Nastia
    • Support Rock Star

    Hello brightfuture333 , hope you're doing well!

    If you edit the /protected/ page, you'll see that this message is added manually. You can delete it from the page contents and update the page

    With credentials that you provided I can access all the protection content pages. Would you please check them again. If I missed any page, please let me know.

    Kind regards,
    Nastia

  • brightfuture333
    • Site Builder, Child of Zeus

    Hi Nastia,
    Thank you for your reply.
    I realize this is a page I created that was meant to be displayed when a user was not a member and trying to access the page. However, the user does have access to the page, but is not able to.
    I've noticed that it actually works using the google chrome browser. I initially tried this using Microsoft Edge. Aren't these programs configured to work with multiple browsers?
    Thanks for your help.

  • Sajid
    • DEV MAN’s Sidekick

    Hello brightfuture333,
    Hope you are doing good today :slight_smile:

    Thanks for enabling support staff access and sharing the test user details. It is developed to work on all browsers and all operating systems. I could not replicate this issue on your site.

    I mean, when I am logged in as administrator I does not get redirected to protected page.

    Later on, I tried to access the Downloads, member's only page and I got redirected to protected page as expected. I then logged in by using the test user account you left in support staff notes and could access the downloads page with no issue.

    I tested it on Chrome and FireFox browsers on Mac Book Pro.

    I asked my colleague to test on Microsoft Edge and he also could not replicate this issue.

    As visitor, this is what he see:

    And this is what he see while logged in as test user credentials:

    If it is still not working for you then please clear your browser cache and then check again.

    Take care and have a nice day :slight_smile:

    Best Regards,
    Sajid - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.