a couple of problems with pro sites

hi.

ok. here are "some" problems i cant solve myself. i have tried, but i am by no means a pro. so please, please, help me. i am really desperate here.
i finally figured out how to setup a link so users can register and signup for a new site in my network. but oh my god...so many problems from there on...
here's the list...and yes, i really tried to find answers in the faq and documentation. i found absolutely nothing that made sense to me.

here's the list:

- the wp-signup appears to be without css. there is no theme or styling going on whatsoever (bgl-navi/wp-signup.php)

- there are no details about the plans users can choose to signup for to be seen. i expected some sort of list that shows the user what he signs up for, and the benefits of one plan over the other. but nothing. absolutely nothing.

- the email confirmation is send. that works. but in the email it asks the user to click on a link to confirm the signup. this link is pointing to http://testsite.bgl-navi.de/wp-activate.php?key=c664e7c2208c5424 when it should point to http://bgl-navi.de/wp-activate.php?key=c664e7c2208c5424
how do i correct that? i tested it, and if i use the second link, i get a success confirmation.

- and now the biggest problem (well, they are all BIG): when i try to go to testsite.bgl-navi.de it tells me, no website configured there. what the hell?

ok guys. we need to sort this out. i hope this support i pay so much for, and never use, is finally paying off :smiley: i really, really, really (!!!) have to get this done by tomorrow. and this is not a joke. i have to show this to a possible partner/customer and if i cant produce the prosites in a at least functioning state (forget about details in design and translation) i am in major doo-doo. i hope you understand.

thank you for your time.
silvio

  • Jack Kitterhing

    Hi there @Silvio

    I hope you are well today.

    Sorry to hear of all the problems you've been having, try this CSS for your signup form, it should work if you add it to your themes style.css

    .mu_register {
        margin: 0 auto;
        width: 90%;
    }
    .mu_register form {
        margin-top: 2em;
    }
    .mu_register .error {
        background: none repeat scroll 0 0 #FFEBE8;
        border: 1px solid #CC0000;
        color: #333333;
        font-weight: 700;
        padding: 10px;
    }
    .mu_register input[type="submit"], .mu_register #blog_title, .mu_register #user_email, .mu_register #blogname, .mu_register #user_name {
        font-size: 24px;
        margin: 5px 0;
        width: 100%;
    }
    .mu_register .prefix_address, .mu_register .suffix_address {
        display: inline;
        font-size: 18px;
    }
    .mu_register label {
        display: block;
        font-size: 15px;
        font-weight: 700;
        margin: 10px 0;
    }
    .mu_register label.checkbox {
        display: inline;
    }
    .mu_register .mu_alert {
        background: none repeat scroll 0 0 #FFFFE0;
        border: 1px solid #E6DB55;
        color: #333333;
        font-weight: 700;
        padding: 10px;
    }

    - there are no details about the plans users can choose to signup for to be seen. i expected some sort of list that shows the user what he signs up for, and the benefits of one plan over the other. but nothing. absolutely nothing.

    I'm afraid this is a default and not something that can be easily changed, though you may be interested in this over here https://premium.wpmudev.org/forums/topic/eyecandy-meets-pro-sites

    - the email confirmation is send. that works. but in the email it asks the user to click on a link to confirm the signup. this link is pointing to http://testsite.bgl-navi.de/wp-activate.php?key=c664e7c2208c5424 when it should point to http://bgl-navi.de/wp-activate.php?key=c664e7c2208c5424
    how do i correct that? i tested it, and if i use the second link, i get a success confirmation.

    That is a very strange error, that's it sending it with testsite, what is the main site defined as? the testsite or the bgl-navi ? Or was testsite moved? :slight_smile:

    - and now the biggest problem (well, they are all BIG): when i try to go to testsite.bgl-navi.de it tells me, no website configured there. what the hell?

    Is that in your network admin > sites, do you see that site there or is there no site there? As your current page on that looks like a holding page.

    Thank you!

    Kind Regards
    Jack.

  • Silvio

    hmm. most certainly not. no, i havent. where and how can i do that? could you explain that to me in a very, very simple way?

    oh, and i tried the css. didnt work. i put into the style.css of the theme, and id opened wp-signup.php too. there was already code in there looking like that. so i made a copy of the wp-signup.php and put the code you gave me in there. renamed it to wp-signup.php and copied it to the server. results in both ways was the same. none at all. the site looks like before. i flushed the cache too. just to be sure.

    ok. maybe that wildcard thing is connected to that?

    but the subdomain is working, or not because if i go to the testsite http://testsite.bgl-navi.de/ i get this telling me the domain works. but then again, if i go to http://testsiteblaaaaaaaa.bgl-navi.de/ it tells me the same thing. and there is definitely no site with that name.

    i see the site http://testsite.bgl-navi.de/ in the admin area for the network: bgl-navi.de/wp-admin/network/sites.php
    but i dont think anything has been set up. also, when i try to connect via ftp, i am in the directory of the main site bgl-navi.de. i dont think it's supposed to do that either, right?

    thank you guys for your help...i really appreciate it!

    silvio

  • Silvio

    no. i didnt redirect it anywhere. all i can think of now that could have messed things up there, is my install of the multisites.

    i setup the multisite thing. after that, i wanted to have bgl-navi as the main site, and subdomains for network.bgl-navi.de and after that every client with subdomains... client.bgl-navi.de

    but i wanted to have bgl-navi as main site. so i didnt give it a subdomain. obviously. in the network admin panel it shows me, bgl-navi.de as a site, and testsite.bgl-navi.de with a subdomain. as i wanted it to.

    but it seems odd to me. because when i go into the settings in the admin panel for the network, i see the path to both sites, and in both it just says: /

    i can understand that it is set like this for bgl-navi.de. since it is supposed to be the main site. but not for testsite.bgl-navi.de.
    shouldnt the path be something like /testsite ?

    also:what is that with "siteurl and home"? it says something about "refresh" there (sorry, it's in german. cant find a better word for it. maybe "rebuild")

  • Dev4

    From what I can see I think that is what is happening... Your WP install is not in the root, you have a redirect sending calls to the root to the correct directory, but the subdomains do not resolve the same.
    Your redirect is only applying to the main domain and not any subdomains.
    You MIGHT be anel to fix this (assuming all my assumptions this far are correct) by adding a redirect that applys to all public domains rather than just the one...
    (don't do that if you have other domains on this VPS)
    another way would be to install WP in the root of that domain...
    (again assuming that i have assumed correctly so far)

    I hate giving advice like this without all the info.. and I am by no means a super expert in the area... but your plea for help got my attention... and maybe this can help

  • Silvio

    yeah. thank you for helping out dve4. i really appreciate it. very nice of you. i just have to get this right. failure is not an option here.

    so. when i hover over the link in the network admin wher i can see both sites listed, it shows me testsite.bgl-navi.de and bgl-navi.de

    however. there are more options available for the subdomain that for bgl-´navi.de.

    the main site has only 3 options. edit.dashboard and visit site (in german. dont know if thats the correct translation tho)

    the subdomain has 7. edit.dashboard.deaktivate,archive,spam,delete,show page.

    is that supposed to be like that?

    when i register a new site, it sends an email:

    -------------------------------------------------------------------

    To activate your blog, please click the following link:

    http://testsite2.bgl-navi.de/wp-activate.php?key=1d868cee3b0cdc45

    After you activate, you will receive *another email* with your login.

    After you activate, you can visit your site here:

    http://testsite2.bgl-navi.de/
    -------------------------------------------------------------------

    that link, again as before, leads into the nirvana. removing the subdomain, it works.
    bgl-navi.de/wp-activate.php?key=1d868cee3b0cdc45

    but again, the link to testsite2.bgl-navi.de is leading into nothing.
    also...shouldnt it create a folder i can see when i connect via ftp?
    and i cant login into the backend via http://testsite2.bgl-navi.de/wp-login.php
    theres also nothing.

    jesus. i think i have to get rid of the whole thing, and start all over again. this is a mess. ffs. any ideas?

  • Dev4

    I just tested this on a subdomain site and it gave me a subdomain link like yours.
    But mine works when I activate at that link.

    Is your wpconfig file set to subdomains?

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'yourdomain.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

  • Silvio

    /* Multisite */

    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'bgl-navi.de');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    this is what mine looks like. is that "yourdomain.com" supposed to be "yourdomain.com"? did i fuck it up by putting my actual domain there? stupid question maybe. but thats the only thing different there.

    and yes, bgl-navi.de is installed in the root. its the only install. i have had setup one subdomain tho. but thats deleted.

  • Dev4

    That looks exactly right.
    I just did a couple test entries on your site, so you might want to delete them.

    I am coming to the conclusion that this has to do with your server set up.
    WP is acting right, but the subdomains are not resolving to your site correctly

    I found another issue,
    when I go to http://bgl-navi.de/wp-signup.php
    I get the sign up page... but with no template.

    Your subdomains are not pointing to the main domain they are pointing to the IP instead... so reinstalling is not likely to help.

    Do you have any support on the server side to help you correctly set up wildcard subdomains?

    When it works, going to test33333.bgl-navi.de/ will take you to a sign up page, or a page saying sign ups are not allowed - depending on your settings.

    Since you MUST have this ready soon... I would see if you can get help on the server first, then if not... quickly set up a demo site on a WP MULTI friendly - shared host site who has c-panel etc. to show your boss/partner how it works.

  • Silvio

    hmm. yes, that's more or less what i thought too.

    i try to get in touch with the hosting company now. lets see what they have to say about the subdomain thing. the thing with the signup page i notice already. mentioned it in this thread here too. i think it doesnt get the stylesheet because of the chaos with the domains. not sure. to me it look like i dont really have a choice but to start over here. something went terribly wrong, and i have no idea where and when. thank god, i have all the clients ready to import. so just reinstalling it is. imprting the data afterwards and that is that.

    thx for your help buddy. this is really, really nice of you. i hope i can repay that some day :wink:

    one question tho, what would be the most sensible way to reinstall now? without losing all the plugins and themes i already uploaded. i dont want to upload everything again. i would just empty the sql and then go to site.de/wp-admin/install.php.

    after that, install wordpress fresh. with multisite support. after that, i setup the sudomains i need, install a main/landing site on the main domain, then subdomains for the client-directory.

    and here i have a question: is it possible to install, lets say, on a subdomain like clients.bgl-navi.de prosites? but then all the clients would have domains like

    company.clients.bgl-navi.de thats

    thats kind of stupid. would it be possible to give them domains like company.bgl-navi.de instead? even if my install of prosites is on a subdomain itself? do you know what i mean?

  • Dev4

    Yes you can do a subomain install if you want to.

    A quick way to do a reinstall is to rename your publichtml file and create a new one..
    Install there - point to a new database..

    That way if you want to go back to the original... it is easy.
    You would have to reinstall the plug ins... but A reinstall without reinstalling the plug ins etc is not real useful.
    And I do not think it will help because I think the problem is on the server settings, not in WP

    If you start with a fresh public html folder and just put a simple page there... index.html page... then you can test subdomains with out WP to take into account.

    All wildcard subdomains should take you to that same page.

    Until that works WP will not work.

    Another way you could go would be to use subfolder instead of subdomain...
    I know that is not what you want, but it would show the functions of the site.
    (it is hard to change later if you actually go live that way)
    But I would bet that it all works perfectly even now with subdomain set to false.

  • Jack Kitterhing

    Hi there @Silvio

    I hope you are well today, thanks to @Dev4 stepping in here to help out, Due to time difference I was asleep.

    I've been reading through all the information supplied in this thread, did you try the CSS I gave in the first post for the signup form?

    Have you now re-installed multisite or have you still get the original installation?

    Would it be possible to take a look at this please?

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site
    - Include cPanel/Control panel access.

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.