A few membership questions (Free user, registration, styling)

Hi, I'm using latest version of Membership and I'm in Sandbox mode.

Here is my membership registration page
1. I'd like to know why the Visitor membership does not include a way for someone to sign up. If it's because the default access level for site visitors is set to Visitor, then how do how I remove this membership as an visible option?

2. I don't have any registered users on my site and I'm unfamiliar with WP registration set-up. I created a test user with Membership and noticed that the confirmation email was sent from a non-descript mailbox on my server, not from my site name. How to fix that?

3. Styling.. are the sign-up buttons supposed to look the way the do? Is there a way to make them look more normal, so the whole button can be seen? Buttons from other WPMU plugins seem to appear fine in this WPMU theme.

  • Emanaku
    • The Incredible Code Injector

    Hi Mark,

    1. Did you attach the "Free Payment Gateway" to the Visitor Subscription? No payment gateway - no "Sign Up" button :wink:

    (2. do not know the answer)

    3. you can put into your stylesheet for your child theme this:
    button.blue { display: inline; }
    I think that will do it ...

    Have fun!!

  • Emanaku
    • The Incredible Code Injector

    Hi Mark,

    1. I have to be more specific: You have to activate the "Free Payment Gateway" in Membership -> Payment Gateways

    2. As far as I can see, the Membership plugin uses the wordpress wp_mail function to send the mail. And there seems to be no setting where you can put your own sender email. The wp_mail puts as sender "wordpress@subdomain.domain" if you are in a multisite install. That is how my confirmation mails are sent out - wordpress@... but the ... includes my subdomain.
    Are you on a multisite install? Do you have a completely different sender email adress?

    (3. like I mentioned above)

  • Kimberly
    • Champion of Loops

    Hi Mark, Emanku has some wise words here. I'll include my 2cents as well if that's ok. :slight_smile:

    1.

    If it's because the default access level for site visitors is set to Visitor,

    BINGO! You will need to remove this from the Public Subscriptions. Or you can create a Free Subscription using the gateway you currently have in place only leaving the cost at $0.

    2. You can use a full featured solution like this: http://wordpress.org/extend/plugins/wp-mail-smtp/
    or a bit more recent and less options http://www.tipsandtricks-hq.com/wordpress-plugin-change-wp-email-from-details-1883

    3. i'll attach a link of what it would look like if you added a
    display: inline; element to your simplemarket/style.css file under the a.button:link, .button {

    You should have plenty to get you going here, if not, just reopen anytime!

    Best,

    Kimberly

  • Mark
    • The Incredible Code Injector

    Okay, all issues fixed! I hope I can get the SMTP plugin to work. I was not successful last time.

    PS - Barry said don't activate the free subscription gateway along with the PayPal (and other?) gateways. They may conflict.

  • Mark
    • The Incredible Code Injector

    Hi Emanaku,

    You're welcome for the rep points - thanks for your help.

    Issue 1 was just me being dumb and new to Membership. I had completely forgotten to drag the "Visitors" access level into the access fields in the Subscription plans area. For some reason, I thought the free Visitor plan was a default setting which automatically recognized the limits of access.

    After that, I just entered "0.00" into the amount of the plan (as Kimberly instructed) and voila, it works.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.