A few strange Custom Press issues that affect seemingly unrelated areas of WP

I’ve discovered a few potential Custom Press issues so thought I’d let you know.


This morning I was in the media library trying to change the TITLE of some images. They weren’t changing. Strange. The ALT tag and other fields were saving but the title kept reverting to what it was before I tried to make the change. I suspected it was due to a plugin. So I deactivated all my plugins and tried again. Low and behold, the title changed as it should do so my suspicion was correct. After trial and error I discovered it was when Custom Press was activated that I couldn’t change the title of any of my media. How odd. I am running CP 1.1.6


Yesterday I updated to the latest version of Custom Press (1.1.6). I later found that all the custom data fields for all of my posts had lost all their data. I tried to revert to a previous version of the post but clearly the post revisions don’t store custom fields. Or if they do, it’s gone from those too. Luckily I have little content to replace so isn’t a major issue for me. If I had, I’d be very annoyed. I have no idea whether this was due to the upgrade but can’t see any other reason why all the data in my custom fields would magically disappear so I’m assuming that was the upgrade that triggered it. Like I say, I don’t know this for sure and I didn’t notice until the following day.

I thought i’d share these two stories to get your thoughts / solutions.