A+ gcal booking gets cleared after the start time has passed (Instead of the end time)

Hello,

I have Gcal integration set up with A+ and everything works well except 1 item.

I book a 13 hour appointment starting at 9:00am- 10pm using Gcal (basically to block off the schedule for a day). This is correctly reflected in A+ before the appointment. once 9:01am hits on the day of appointment, the appointment Disappears from A+ (I checked the Reserved by Gcal tab and it is no longer there)

This allows people to book online for appointments during the scheduled blocked off time which is not acceptable. ( i am assuming that the fix would be to make sure the Gcal scheduled appointment stays in A+ until the end of the appointment vs removing at the beginning, however i am not sure how to make this change.)

Please let me know how to fix this issue.

-Dominic

  • Tyler Postle

    Hey Dom,

    Hope you're doing well today and thanks for your question!

    Is the appointment getting confirmed when it is added to WordPress?

    Is this only happening with the long appointments or is it happening with all appointments imported from gcal?

    As far as booking a day off, you could also use the "Exceptions" tab in your Appointments+ settings. This allows you to select specific days off. ie. holidays, vacations, etc.

    Look forward to hearing back on this!

    Cheers,
    Tyler

  • pxwm

    Hi @Tyler Postle - I hope you don't mind me chiming in

    Hi Dom @dcayme1

    I seem to recall a post earlier in the year where the member had a similar problem.
    I've managed to locate the post for reference which is:
    https://premium.wpmudev.org/forums/topic/appointments-booking-conflictoverlapping-bookings

    The resolution of the problem was an upgrade to A+ to v1.4.1/1.4.2 so assuming you have the latest version v1.4.4 then hopefully all you will need to do is the following:-

    Login to your Wordpress Dashboard as Admin
    Select 'Appointment's and 'Settings'
    Then select the 'General' tab
    Then in the 'Time Settings' section locate the 'Time slot calculus method' settings
    Then set 'Detect overlap'
    Reading the original post it indicates you have to also have 'Service duration based calculus' set

    Then Save
    Then try making an appointment/blocking out a time in GCal as before to confirm if this resolves your problem.

    I hope this helps
    Regards
    SteveB

  • dcayme1

    Steve,

    I have the latest A+ installed.

    All the setting are as you stated except:

    Minimum time based appointment duration calculus (legacy)

    is being used. I need this as the way i am booking, 'Service duration based calculus' won't work.

    @ tyler. i just tried doing it for a 30min timeout. Again, the appointment booked under gcal was cleared at the beginning of the appointment (instead of the ends). Is there any resolution for this?

    Exceptions only does whole days. if i need to block of 4 hours of a day, i cannot do it with exceptions.

    -Dom

  • dcayme1

    FYI, i am running A+ 1.4.4

    The previous posters issue was very similar, however the issue was appointments booked in A+ were not booking until the appointment completion time. This was fixed by having the program check the "Completed appointments" folder for the end time and keeping it blocked until the appointment ended.

    My problem is that appointments reserved by Gcal are not carried over into the "completed appointments" section. they are just wiped from the database. As such, A+ no longer knows when the Appointment reserved by Gcal ends.

    Is there a way to code it so that "completed appointments" in Gcal are not automatically deleted at the start time but instead relocated to the "Completed appointments" section? This would fix the problem i believe.

    -Dom

  • Tyler Postle

    Hey Dcayme1,

    Thanks for all the additional info and screenshots here!

    I'm seeing a lot of errors in your Appointments+ logs. Looks like it's for each appointment that's brought over perhaps - it's mentioning invalid credentials.

    You may want to go over the integration process again just to make sure all the fields are correct - although, if it's importing them into WordPress there shouldn't be a big issue there. When the appointments first get imported in what are they set as?

    Check your logs in Appointments+ > Settings > Logs tab. Perhaps the timelines there might give you a better idea of what is occurring.

    Look forward to hearing back.

    Talk to you soon.

    Cheers,
    Tyler

    PS. @pxwm - Steve you're always welcome to chime in on any post you like! :slight_smile: thanks for the assistance here.

  • dcayme1

    Tyler,

    I checked my logs...those are all old issues so i cleared them out. I just booked an appointment via gcal for 1:20am at 1:18am.

    The appointment showed up in my "Reserved by GCal" tab as ID #297. It correctly blocked of 1 hr (1:20am- 2:20am).

    Once 1:21am passed, ID #297 was relocated to the "Removed appointments" Tab.

    As such, A+ has no way of knowing that it should block off the hours from 1:20am-2:20am. Is there a way to fix this issue?

    Maebe the Gcal appointment can be moved to the "Completed appointments tab instead?" that way A+ can still look it up as it does for appointments booked through A+.

    Additionally, When i open ID #297 in the "Removed appointment" tab it states the following:

    Created: 9/27/2014 @1:18 am (correct)
    Start: 9/27/2014 @12:00am (incorrect)
    End: 9/27, 2014 @2:20am

    So it appears that when ID297 is transferred from the "Reserved by Gcal" tab to the Removed appointments, it defaults the start time to 12:00am but keeps the correct end time. Don't think this matters at all since A+ doesn't integrate anthing in the "removed appointments" anyways.

    Let me know if the problem is clear or if you need more info.

  • pxwm

    Hi Dom @dcayme1

    Many thanks for the clarification and I would suggest this very much sounds like a problem relating to the 'Disable pending appointments after (mins)' field in the @general' tab 'Time Settings' section.

    Having re-read the notes related to this field:-

    Pending appointments will be automatically removed (not deleted - deletion is only possible manually) after this set time and that appointment time will be freed. Enter 0 to disable. Default: 60. Please note that pending and GCal reserved appointments whose starting time have been passed will always be removed, regardless of any other setting.

    I think I know what the problem is and would appreciate if you could try the following:-

    Make an appointment from your Google calendar for say 30mins time so A+ has time to sync up.
    Then login to your Wordpress dashboard as Admin
    Then check and confirm the appointment is in the 'reserved by GCAL' tab.
    If it is could you check that the time is correct. I appreciate you have already done this but just want to make sure the correct time of the appointment has been captured.
    If it is could you then 'Confirm' the appointment and Save the changes
    Then say after 5 mins of the start time check that the appointment is still active.

    If it is then as per the notes related to the 'Disable pending appointments after (mins)' field then I would suggest A+ is working correctly as it would appear you have to change the status of an appointment made through your Google calendar from 'reserved by GCAL' to 'Confirmed' otherwise it is removed immediately after the start time.

    I appreciate this functionality may cause you a problem but hopefully it will allow you to move forward.

    Regards
    SteveB

  • dcayme1

    Steve,

    Thanks for the input. I agree that A+ is working as intended. However the way that is intended, does not function as needed to book properly with GCal.

    I believe that you are right. Gcal appointments need to be changed to confirmed appointments. Unfortunately, Any appointments made under Gcal CANNOT be edited. You can physically change it, but there is no button to save the changes.

    The time is correct as long as it is made under 30 minute intervals starting on the hr (ie,12:30, 1:00, 1:30, 2:00 etc).in terms of blocking of the correct time however, it still does it accurately even though it may read wrong.

    Any way to change a "Reserved by Gcal" event to a confirmed event? again, there is no save button in the "Reserved by Gcal" tab. it also specifically states that (details cannot be edited)

    Regards,
    Dominic Cayme

  • pxwm

    Hi @Tyler Postle,

    I would appreciate if you could test/investigate the issue below. I've tested back to v1.2.8 and the same issue applies but I find it strange that you cannot change the status of an appointment that has been 'reserved by GCAL' and then Save.
    I'm pretty sure in earlier versions you could this.

    Hi Dom @dcayme1

    Many thanks for the further feedback.
    I've just checked this and you are right.

    However I find this functionality strange because if for instance you changed an appointment with any other status to 'reserved by GCAL' and then Saved then you cannot move that appointment to any other status.

    I would also suggest that the note associated with the 'Disable pending appointments after (mins)' field indicates that you have to have the functionality to change the status of the appointment if it has a status of 'reserved by GCAL' otherwise they would be removed after the start time.

    Regards
    SteveB

  • Tyler Postle

    Hey Steve and Dom,

    Thanks for all the additional information here :slight_smile:

    @Steve, from what I remember you haven't been able to change the status of the appointments; however, I have only been with DEV since near the beginning of the year - so perhaps that was before my time here?

    With that said, I did test this out and got the same result, as soon as the gcal appointment starts, it removes it. This shouldn't be happening. I am flagging the developer so we can get his feedback on the matter :slight_smile:

    I would also suggest that the note associated with the 'Disable pending appointments after (mins)' field indicates that you have to have the functionality to change the status of the appointment if it has a status of 'reserved by GCAL' otherwise they would be removed after the start time.

    This is a good point as well, if it's true that we can't save change the status.

    Thanks again for all your feedback guys! Talk to you soon. Developers are often busy with their projects so they may take a little bit longer to respond than normal.

    Cheers,
    Tyler

  • pxwm

    Hi @Tyler Postle

    I'm aware v1.4.5 has just been released and wanted to check if @Vladislav had considered my comment above about not being able to change the status of an appointment made through GCAL which is placed in the 'reserved by GCAL' tab?

    I ask because I notice in a recent post: https://premium.wpmudev.org/forums/topic/appointments-wont-sync-current-event-from-gcal that the new version has resolved a similar issue for long duration appointments.

    I'm unsure how an appointment can be managed by Admin if you can't change the status.

    I've also noticed that if you have an appointment with any other status and you change it to 'reserved by GCAL' you can no longer change the status.

    Regards
    SteveB

  • Michelle Shull

    Hi SteveB! You are a very helpful member, I wanted to say thanks for always chipping in when you see an issue, it's really appreciated by all of us. (Throwing you some rep points, too.)

    As to the latest release, these are the release notes:

    - Fix for issues with searching appointments.
    - Fix for markup filtering breaking the shortcode arguments.
    - Fix for Service name being truncated if it contains a dollar sign (props Jose).
    - Fix for long-running GCal appointments display issue.
    - Added automatic completion for additional fields (props Jose).
    - Added worker and service expansion in schedule titles.
    - Added Google+ login support.
    - Added removal notification email

    i don't see the GCal status issue addressed directly here, but I"m happy to throw up a flag for Vlad to get his input.

    Thanks, Steve!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.