A lot of membership automatic emails are not sent

I have set custom automatic emails to be sent for my members, but most of them are not being delivered, I also want to disable the new user notification and keep track of all my emails.

  • Predrag Dubajic
    • Support

    Hi Mary,

    Hope you're doing well.

    I was doing some tests on my installation based on the info in chat but I couldn't replicate the issues so I did some additional tests on your installation.

    The first thing is that I was unable to register because of the username was showing as invalid, now as a temporary workaround I've enabled username field and I was able to register after that.
    I see that you tried the conflict test for the email but could you do the same and disable your other plugins and switch to default theme so we can see if the registration works fine after that even with username field disabled?
    This should help us to pinpoint the issue so we can investigate it further.

    So to continue with the registration and emails, since you are using live PayPal details I switched it temporarily to my sandbox account and after the registration was completed I got the confirmation email no problem, you can check the attached screenshot of that email.

    Also, if you go to Membership 2 > Help > Email History tab you will see that the email was sent.
    It seems like the payment wasn't properly completed during your tests and that's why the email wasn't sent out.
    Can you check if your PayPal details are correct and then give it another try?

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.