A+ running slow when switching between providers

For some reason, A+ is running slow. It loads pretty fast initially, but it slows down when switching between providers or services.
I tried deactivating all the plugins, but the problem persisted.
Could you please advice on how to proceed to sort out this problem.

  • Ash
    • WordPress Hacker

    Hello San

    Would you please send me a link to the page where you have the booking form? I have checked your site but didn't see the booking page.

    Also, did you check with the default theme? Is it still too slow with the default theme?

    Please let me know about this. Have a nice day!

    Cheers,
    Ash

  • San
    • Flash Drive

    Hi Ash,

    The page is http://www.repics.com.au/booker

    You have to be logged in to access it.
    I have granted support access. I'm not sure if that is sufficient.
    I have contacted WPMU before about this issue, and I've tried all the usual suggestions.
    Turned off all the plugins and changed theme. It loads ok initially, but when you change through service providers or services, it takes a long time to refresh.

  • Nithin
    • Support Wizard

    Hi San,

    Hope you are doing good today. :slight_smile:

    I checked the mentioned page, and I could notice the issue. I also tried creating a test page, and could notice the same. However, the site in general seems to be a bit slow, for example loading the dashboard pages, and editing pages etc

    Could you please enable debug mode, and see whether it would give a better idea where the issue is located.

    To enable debug mode, open your wp-config.php file located in your root directory, and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add:

    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    define( 'SCRIPT_DEBUG', true );

    After making the above changes, please try to replicate the issue. The related errors will be saved to a debug.log log file inside the /wp-content/ directory.

    Please attach these in your next reply in txt format file, so that we could give a closer look. You can find more details about debugging here.

    I could also notice your site is running on PHP 5.6, and memory limit is 128M, which is low. You can check the following article on how to increase memory_limit:
    https://premium.wpmudev.org/blog/increase-memory-limit/

    If you aren't sure about making the above changes as mentioned in the article, or whether the above isn't working. Would recommend you to check with your hosting provider, and ask to increase the memory_limit to minimum 512M, and also ask to increase the PHP version from 5.6, to at least 7.0, or greater.

    PHP 7.0, and greater versions are considered very fast when compared to version 5.6, and it should improve your sites overall performance.

    Please let us know how that goes, have a nice day ahead. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.