Abandon ship! How do I move all content to another site?

I've been having so much trouble with MailPoet and two subsites that I've decided to completely rebuild them. How can I move all the content including media and comments to a new subsite?

  • Mike D
    • The Bug Hunter

    Thanks Calvin, it mostly worked but I'm struggling with the users. Snapshot gives a big warning not to restore the global user tables so I didn't but now the new site does not have the old users. How do I move the users from one subside to the other and retain the connections to their posts and comments?

  • aristath
    • Recruit

    Hello again @Ocean Digital Corp,

    Another way to export/import content is using the default WordPress exporter & importer.
    From your old site go to Tools => Export and download the exported content from your site.
    On your new site go to Tools => Import and select the WordPress importer. You will then be able to import the file you downloaded from your previous site.
    As for your users, you can export them from your old site using this plugin: https://wordpress.org/plugins/export-user-data/ and then import them to your new site using this one: https://wordpress.org/plugins/import-users-from-csv-with-meta/

    I hope that helps!

    Cheers,
    Ari.

  • Mike D
    • The Bug Hunter

    I found a much faster way to move users, Network Admin>Sites>edit the new site you want to add users to. You can manually add users there. Do I get a point for discovering that? :slight_smile:

    However.....

    My posts are still messed up, check out the way they looked on the old site: http://25earlingtonold.oceandigital.ca
    You can see dates, comment count and category on top of every post summary and the comments are missing. Where are these things in the new site?! 25earlington.com. I have comments on, debug off, same template, checked template customizer and added the old users. Oh, and I'm missing the sidebar on the Blog page. I think that is because of some css code Aristath gave me last week to hide sidebar on the Real Estate page. It ended up hiding sidebar on two pages instead of one.

    Can you guys help me restore these missing things?

  • Tyler Postle
    • CGO

    Hey there Ocean,

    I changed your permalinks from /year/month/day to post name instead. It was giving all your post links only the year month day and no post name which mean it would just show the archives for that day instead of the actual post. Now it showing the post :slight_smile:

    As for the date, if you go to:

    Appearance > Customize. Then you can go down to the post section and there will be some checkboxes :slight_smile:

    I've checked the ones that I think you want, screenshot attached.

    Hope this helps! Let me know if there is anything else you still need fixed up :slight_smile:

    Your sidebar is back too, it wasn't showing before because it was an archive page.

    Look forward to hearing back.

    All the best,
    Tyler

  • Mike D
    • The Bug Hunter

    Those Posts settings in the Customizer were not there before! Now im doubting my eyes. As for the permalinks, I did not know they could affect the behaviour like that. I appreciate you getting those things sorted, however that happened but I still do not have a sidebar on this page, http://25earlington.com/posts/

    I think I mentioned earlier, Aristath from WPMUDEV gave me this CSS

    body.page-id-220 div#primary {
      width: 100%
    }
    body.page-id-220 div#secondary {
      display: none;
    }

    to use to hide the sidebar on this page, http://25earlington.com/real-estate/ but it ended up killing the sidebar on both pages. How do I restore the sidebar on this page http://25earlington.com/posts/ ?

  • Tyler Postle
    • CGO

    Hey Ocean,

    No problem, happy to help :slight_smile:

    It looks like real-estate is a normal page, while "posts" might be set as your blog page right? Looking at the code, it doesn't appear that a sidebar exists on the posts page, which makes sense if it is set as your blog page because that would make it an archive and non of your archives have a sidebar. There might be an option to enable the sidebar for archive pages in your theme, is there?

    Your support access has expired, otherwise I would of checked for the option myself.

    Look forward to hearing back here Ocean!

    All the best,
    Tyler

    PS. You could also try out our Custom Sidebars Plugin: https://premium.wpmudev.org/project/custom-sidebars-pro/

    it allows you to easily manage where your sidebars are located.

  • Ash
    • WordPress Hacker

    Hello @Ocean Digital Corp

    I hope you are well today.

    I have logged in at your site but the http://25earlington.com/ subsite is not responding. Would you please confirm?

    Also, would you please edit the Blog page from admin and in Page Attribute widget check if there is any option for sidebar page. Select that template, save and check the page.

    Please let us know.

    Cheers
    Ash

  • Mike D
    • The Bug Hunter

    I just logged in, seems to be working ok. There is no attribute to change the sidebar on the page settings. Like I mentioned earlier in this thread, when Aristath gave me css to kill the sidebar on the real estate page, it removed it from the blog page also. The problem must lie with the css he gave me. I pasted it into Simple Custom CSS plugin.

  • Mike D
    • The Bug Hunter

    Ok, just for reference. I removed the css in question and the sidebar did not reappear so it's not what I suspected.

    I'm going to close this thread and open a new one that's more focused on adding a sidebar to the page I want.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.