About Upfront Software/Theme — Won't Load (Tried Everything)

I’m not sure why I’m having so many issues with WPMU in general. I thought this was supposed to make my life easier, not harder.

Anyway…I did a lot of research regarding why the Upfront Theme Editor will not load, and STILL have not resolved the problem. Will you please take a look for me? I already granted access to staff.

Thanks,

Julie

  • Vinod Dalvi
    • WP Unicorn

    Hi Julie,

    Sorry to hear of the problem you are having.

    I logged in to your site using support staff access and could confirm the issue that the upfront editor is not loading but just displaying the loading symbol.

    I tested it on my test site using latest version of Scribe theme and found it's working fine without any issue.

    I troubleshooted the issue on your site and found the following javascript error message is displayed in the browser console when i try to activate the upfront editor mode as shown in the attached screenshot.

    Uncaught SyntaxError: Unexpected token ?

    Would you please try disabling Pagespeed module in your server?

    Here are some instructions how you can disable: https://wiki.bitnami.com/Components/Apache/PageSpeed

    Try placing the following snippet in your .htaccess file at the root of your site it will skip mod_security rule that blocks access to the popup.html theme file.

    <IfModule mod_security.c>
    SecFilterRemove 00318
    </IfModule>

    You are using a PHP version that is no longer supported( See the second attached screenshot ) as described on the following page so could you please try updating it to the latest version by contacting your web host?

    http://php.net/supported-versions.php

    Best Regards,

    Vinod Dalvi

  • JulieAnne
    • Flash Drive

    Thanks. Didn’t realize this was all some advanced stuff way over my head. I pray that when I get done learning all this, I can make money doing this for other people. LOL Anyway, I will see how it goes and post an update later.

    I probably have pagespeed turned on in my Dreamhost CP. I will probably be able to just shut it off there.

  • JulieAnne
    • Flash Drive

    Okay, yeah…I notice it goes up to PHP 5.6 on the list of choices for PHP versions (in my Dreamhost CP). Should I pick the latest one?

    The only bummer about disabling Pagespeed is that without it I can’t run the Google Analytics. I suppose unless I knew another code that helped me do this anyway, but that’s beside the point.

    I will see how it goes in a few minutes.

  • JulieAnne
    • Flash Drive

    Okay Upfront loaded, thanks for your help. Sorry I blamed WPMU Dev. It’s not your fault. Now, I just need to figure out how to get my posts and pages to show up…

    This is my first time using this, so if there’s any manuals about Upfront — how to get my existing pages and posts to show up, please let me know.

    But I think I might know…

    Am I supposed to make the scribe theme a child of Upfront? I think I saw that somewhere.

  • Vinod Dalvi
    • WP Unicorn

    Hi Julie,

    Glad it’s working fine for you now.

    This is my first time using this, so if there’s any manuals about Upfront — how to get my existing pages and posts to show up, please let me know.

    By default existing pages and posts are displayed using default upfront theme templates.

    You will find more information about usage of upfront themes on the following page.

    https://premium.wpmudev.org/blog/tag/upfront/

    Am I supposed to make the scribe theme a child of Upfront? I think I saw that somewhere.

    All the upfront themes like scribe theme are child themes of Upfront parent theme so before using child theme you should install the upfront theme on your site.

    Cheers,

    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.