Access Akismet Configuration Page in Network Admin mode?

I find that when trying to access the Akismet configuration page from the plugins page in Network Admin mode, I am given the error “You do not have sufficient permissions to access this page”.

Any suggestions ?

Thanks

PC

  • PC
    • WPMU DEV Initiate

    I also tried creating two test sites under my multisite, for one I was able to access the configuration page for akismet, but for other, I was not.

    FYI – I have no plugins installed apart from akismet and jetpack as of now. and jetpack is disabled

    :slight_frown:

    Please help

    PC

  • 3SixtyEvolve
    • New Recruit

    Hi PC

    Hope you’re well.

    This sounds like a permissions issue with a folder on your Multisite install, probably the Akismet folder. Please check to see if the permission level is 755. If it’s not this, then try to uninstall the plugin and reinstall it via FTP.

    Let me know if any of this helps.

    Have a good day!

    Gina

  • PC
    • WPMU DEV Initiate

    Hello Gina,

    I checked the Akisment folder it has the correct permissions. and as the other suggestion, I did not only try to reinstall Akismet, but even did a complete network reinstall, Its just that as a network admin(Super Admin), even after network activatiing the plugin I am unable to get the Akismet config page.

    On the other hand, I am able to view the page as admin of any other site in my multisite install.

    Is it like that I would not be able to access it as a super admin but a normal admin

    Cheers

    PC

  • Sue
    • Recruit

    Hi PC

    My understanding is that you need to hard code the API key to set it up network wide, you can’t do it from your network admin and it is normal to see the “You do not have sufficient permissions to access this page” when you click on the Settings page from the network admin dashboard.

    You do it by adding the following to wp-config.php:

    /** Define WordPress.com API Key */
    define('WPCOM_API_KEY','your_api_key');

    But if you activate it network wide you must have an enterprise license: https://akismet.com/signup/

    Thanks!

    Sue Waters

    Edublogs Support Manager

  • PC
    • WPMU DEV Initiate

    Heya Sue,

    Thanks for looking over my issue. I was pulling my hair off researching for it.. Now m happy that its a normal behaviour.. and also I got an answer to why it was not being activated for all my network subsites, I do not have a enterprise license. as I already tried to hard code that and when I checked on my test site under the network, it was not there and was giving me an option for entering my Akismet key.

    Cheers

    PC

  • Sue
    • Recruit

    Hi PC

    Glad my information helped.

    When set up correctly network side you won’t see the message asking you to “Enter your API key” on your other sites and when you go to Plugins > Akismet Configuration in the dashboard of any site it’ll confirm it is set up correctly.

    Thanks!

    Sue Waters

    Edublogs Support Manager

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.