Access has been blocked.

Hi .

Now I get this message again when I try to get access to my site http://www.albertesmarked.dk:

Access has been blocked.

Your IP [87.56.240.35] is registered in the Stop Forum Spam or Project Honey Pot database.
If you feel this is incorrect please contact them

Protected by: AVH First Defense Against Spam - WPMU DEV Version

I have check on "Stop Forum Spam" and "Projekt Honey Pot" and my IP is not listed as block.

Yesterday I disabled the use of the two 3rd Party Options in "Comment Spam Pack".

I'm a little frustrated. Have to have a comment / forum spam filter on my site.
Hope you can help.
Best Tim

  • aristath
    • Recruit

    Hello there @Alkamus, I hope you're well today!

    Perhaps your current IP was previously used by a spammer...
    Could you please try turning your Router off for a couple of minutes and then back on again?
    This usually changes your IP address so you should be fine.

    I hope that helps!

    Cheers,
    Ari.

  • aristath
    • Recruit

    Could you send me your admin credentials? Just so that I may check from your administration if there's something wrong there...

    Send an email using our secure contact for on this page: https://premium.wpmudev.org/contact/
    - Mark to my attention
    - Include a link to this page so that i may track this issue more efficiently
    - Unclude a link to your website
    - Unclude your admin credentials (user/pass). Please note that if this is a multisite installation I'll need superadmin.

    Cheers,
    Ari.

  • aristath
    • Recruit

    Hello there @Alkamus, I'm sorry for the long delay but I was in bed with a high fever. I still haven't recovered fully, but at least I'm able to work now.

    I also use "Anti-splog" and "Wordfence". Is it necessary to use the "Comment Spam Pack" when these two are activated?

    Anti-Splog prevents the creation of spam blogs on your network
    Wordfence is a general security plugin
    The comment spam pack deals with comment and trackback spam.

    They are all different plugins and deal with different aspects of your site.
    So the short answer is that yes, it is necessary.

    Cheers,
    Ari.

  • Shawn
    • The Crimson Coder

    I see no reason why they can't be used together - they affect different areas of the site so aren't really either/or plugins. Most likely you have a rule or setting in Wordfence that's causing it to be overly aggressive. I'll play with it later today and see if I can figure out what might have caused your problem.

  • Tim
    • The Crimson Coder

    Hi Shawn.

    Now I have installed the "Comment Spam pack" again and activated it all. Are there some settings that you think is more important then others. I'm new at this point so is a little unsure.

    Best, Tim

  • Shawn
    • The Crimson Coder

    This is entirely the fault of the Wordfence firewall module. I don't think it's possible to purge the settings since you can't gain access to the interface, and if you remove the folder and then visit it you won't be able to reinstall it to deactivate it without re-enabling the very feature that is broken. Sigh. What a pain.

    The options appear here:
    SELECT name,trim(val + '') FROM wp_wfConfig;
    It looks like you want to set this:
    update wp_wfConfig set val=0 where name='firewallEnabled';

  • Shawn
    • The Crimson Coder

    If you have access to phpMyAdmin or something similar (something to edit the database data directly) then you'll want to run the second command against your database. The table name might be different from what appears there - but this is the most likely command. If it returns an error then it didn't work. If it doesn't then you should be able to access your site immediately.

  • aristath
    • Recruit

    @Alkamus I can't visit your site either...
    Can you send me your FTP details so that I may try some things and figure out what's wrong?

    Send an email to aristath AT incsub DOT com
    - Include a link to this thread so that I know what issue it's about
    - Include your FTP details (server/user/password)
    - Include a link to your site.

    Cheers,
    Ari.

  • Tim
    • The Crimson Coder

    Hi Ari.

    I have activated the "Comment Spam Pack" and now this:

    "Access has been blocked.

    Your IP [87.56.240.35] is registered in the Stop Forum Spam or Project Honey Pot database.
    If you feel this is incorrect please contact them

    Protected by: AVH First Defense Against Spam - WPMU DEV Version"

    Best, Tim

  • Tim
    • The Crimson Coder

    Hi Ari.
    I have not solved the problem. When I enable the "Comment Spam Pack" then closes the access to my website very soon after.
    The information I sent to you by email, can they be used?

    Hope you can solve this problem as it is important.

    Best, Tim

  • aristath
    • Recruit

    Yes, I got your email but for some reason I could not login yesterday. I'll try again today.
    In the meantime, have you tried disabling WordFence and see if that fixes your issue?
    I'm simply trying to understand if this is an issue that involves only the Comment Spam Pack plugin, or if this is a conflict between plugins.

    Cheers,
    Ari.

  • Tim
    • The Crimson Coder

    Hi Ari.

    I did not use "Wordfence" when the problem occurred for the first time.
    I would deactivert it and see what happens.

    I have seen another member of WPMUDEV asked the same questions with the same message. Can not find it now, but seem to remember that he also did not resolve the problem.

    Best, Tim

  • Tim
    • The Crimson Coder

    Hi Ari.

    Now I have activatet theise plugins (Comment Spam Pack)

    Let's see what happens.

    - AVH First Defense Against Spam - WPMU DEV Version
    - Trackback Validation (AVH F.D.A.S Component)
    - Spam Filter (AVH F.D.A.S Component)
    - ReCAPTCHA (AVH F.D.A.S Component)
    - Asirra (AVH F.D.A.S Component)

    Best, Tim

  • Tim
    • The Crimson Coder

    Hi Ari.

    First thing I do when the plugins was activatet was to click on my main site and clicked "Visit Site".

    Then this came up:

    "Access has been blocked.

    Your IP [87.56.240.35] is registered in the Stop Forum Spam or Project Honey Pot database.
    If you feel this is incorrect please contact them

    Protected by: AVH First Defense Against Spam - WPMU DEV Version"

    I did nothing else.

    Best, Tim

  • Shawn
    • The Crimson Coder

    Out of curiosity, what version of PHP and MySQL are you running Tim?

    Perhaps this is happening because the __construct function isn't running, which means that the REST request isn't successfully returning but also isn't generating an error, so the function returns and could be treated as a positive check.

    Another thought - do you have the table wp_avhfdasipcache within your database? If for some reason this table wasn't created then it's possible that the issue is related to the table not existing.

    If the table does exist, please check it to see if your IP appears within the database using the following syntax:
    select * from wp_avhfdasipcache where ip=INET_ATON(1.2.3.4);
    Replace 1.2.3.4 with your IP address.

    Finally, please check the table structure for wp_avhfdasipcache to see if the field 'ip' is created as unsigned. This could also be related to an overflow in this field.

  • Tim
    • The Crimson Coder

    Hi Shawn.

    Thanks for your reply and curiosity regarding my problem.

    First to be said that I am a beginner in this field. Have not worked much with codes, etc.

    My PHP version is: 5.3.21
    MySQL version is: 1.5.68-cll

    I'll try to examine what you have suggested.

    I will return.

    Once again, thank you for your help.

    Best, Tim

  • Shawn
    • The Crimson Coder

    Can you verify your MySQL version please? I'm assuming that 1.5.68 is actually 5.1.68, right?

    Don't worry about the __construct thing - your version of PHP supports it.

    You'll find (or at least be able to look for) wp_avhfdasipcache within phpMyAdmin.

  • Vladislav
    • Dead Eye Dev

    Hello,

    Can you please try the attached Beta update and see if it helps? The attached version has a bit more tightened http:BL response processing, which would hopefully help in your situation. Also, to make sure we're not dealing with an old response gone wrong, can you please turn off the IP caching in AVH plugin? You can do so by unchecking the "Use IP Caching" option, in the General Options section of the plugin settings.

  • Tim
    • The Crimson Coder

    Hi Vladislav.

    I have activated the beta-version.

    When I try to "Visit site" I get this message.

    "Access has been blocked.

    Your IP [87.56.240.35] is registered in the Stop Forum Spam or Project Honey Pot database.
    If you feel this is incorrect please contact them

    Protected by: AVH First Defense Against Spam - WPMU DEV Version"

    Best, Tim

  • Tim
    • The Crimson Coder

    Hi guys.

    I have deactivated "Stop Forum Spam" and "Project Honey Pot" in "Comment Spam Pack". This seems to work.

    I didn't found out what the problem was but now I try this.

    Thanks for your patience. If this solution does not work, I will return.

    Best, Tim

  • Scott
    • New Recruit

    The same things happens to me as well
    "Your IP [70.92.69.74] is registered in the Stop Forum Spam or Project Honey Pot database.
    If you feel this is incorrect please contact them

    Protected by: AVH First Defense Against Spam - WPMU DEV Version"

    I have tried from a couple different locations with different IP's same thing.

    IP caching is disabled.

    I will have to try the Beta that was posted above a couple days ago and see if that works.

  • Shawn
    • The Crimson Coder

    The thing is - these IP addresses aren't actually in either Stop Forum Spam (SFS) or Project Honey Pot (<a target="_blank" href="http://www.projecthoneypot.org/search_ip.php
    ">PHP).

    That leads me to suspect that it's actually a false positive due to a query lookup with a negative default. This would result in a failure to perform the lookup for any reason (such as the cache table not existing, no curl, dns lookup failure, outbound connection throttling by the host or permissions issues) as treating *every* IP that connects (which appears to be what's happening) as though it's in these databases when it's not.

    The only way to identify the problem is to put a few echo's in there to see exactly where it's failing. That will let us answer these questions: Are the sites being resolved by the server? Do the tables that are supposed to be created by the plugin actually exist? Are the versions of PHP & MySQL current enough that they support the functions that are being used? Are these functions disabled within PHP or MySQL for some reason? Do *some* requests work while others fail (indicating throttling)?

    Anyway... that appears to be where we're at on this. It's likely that different people experiencing the problem have different issues. One might have DNS failures while another might be experiencing throttling. In any case, the solution is the same: instead of a "default block" it should be coded to "default allow" all connections.

    15-20 years ago there was an article that said something like "the only *secure* computer is unplugged, sealed in cement and placed in a bunker 200 feet below the surface. It's secure, but also completely useless." I'm afraid that the default block scenario we're seeing here is a perfect example of the computer in the bunker.

  • Scott
    • New Recruit

    A. Kloxo-MR: 6.5.0.f-2013031812

    B. OS: CentOS release 6.4 (Final) x86_64

    C. Apps:
    1. MySQL: 5.5.30 MariaDB
    2. PHP: php53u-5.3.24-1.ius.el6.x86_64
    3. Httpd: httpd-2.2.24-1.el6.x86_64
    4. Lighttpd: --uninstalled--
    5. Nginx: nginx-1.5.0-1.el6.x86_64
    6. Qmail: qmail-toaster-1.03-1.3.22.mr.el6.x86_64
    7. Dns: bind-9.9.2-3.P2.el6.x86_64

    D. Php-type (for Httpd/proxy): php-fpm_worker

    There are the versions of everything on one of my servers.
    I use Nginx as a proxy with Apache as it made a huge difference in performance!

    Must be some issue going on with the plugin and my setup, but as long as I turn the Honey Pot section off, all is good. I tried the beta version posted above and found the "image question" part i think which was added in on the beta. That did not work out as I had about 50 spam comments when I woke up thing morning to trash lol.

    Much better results with the Captcha.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.