Access levels aren't working with new membership plugin

Hello, my site uses membership in order to turn off the ads. What we do is we use the short code that will show up for everyone who isn't level one (the paid membership). This worked with membership1 but it doesn't work with membership2. Will the levels feature be added in the future and can you do this with membership2. Thanks in advance.

  • Vinod Dalvi
    • WP Unicorn

    Hi Jack ,

    Sorry to hear of the problem you are having.

    What we do is we use the short code that will show up for everyone who isn't level one (the paid membership). This worked with membership1 but it doesn't work with membership2.

    Please make sure you are using the proper membership shortcodes having correct membership ID as following.

    [ms-protect-content id="1"] Only members of membership-1 can see this! [/ms-protect-content]

    Also enable the "Shortcode Protection " add-on from the following path.

    Admin Area -> Membership2 -> Add-ons

    If this doesn't help you then please share me the page URL where you are using the shortcodes so that i can test it and would you mind if I logged in to your site and did some troubleshooting? This might help get to the bottom of this faster. If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings as described on the following page and reply on this thread after granting it?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Also I imported the settings from membership1 and the settings changed from monthly (user gets charged the first) to being a one time payment. Is monthly not a part of this plugin?

    The monthly is a part of this plugin and you can set it from the membership payment options as shown in the attached screenshots.

    How have you imported the settings?

    Could you please try configuring it manually as displayed in the attached screenshots?

    also I'm using the tos plugin and the terms are repeated twice on the register page

    It seems the known issue which we are working on to resolve it.

    Could you please try using the solution posted in the following reply to resolve it?

    https://premium.wpmudev.org/forums/topic/tos-is-shown-double-on-register-page#post-873845

    Best Regards,
    Vinod Dalvi

  • Jack
    • Flash Drive

    Thanks... I granted access for the first problem. I use text widgets to display ads for people who arn't paying (visitors and free tier). So to fix it you have to go to widgets and then the text boxes labeled ads.

    Thanks again man : )

    edit: The option to change the payment type is not available. It only says payment gateway and then trial. I switched from membership1 to membership2 today with the current release (update 1.0.0.3)

  • Jack
    • Flash Drive

    I tried doing the membership on my own. It really didn't work. I want to show everyone including visitors the ad but not members. This is something that really needs to be added soon. If not do you guy's have a copy of the original membership so I can use that while this gets fixed. Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.