Accounts page doesn't show subscription status

I now have memberships who are up for renewals. I initially thought the Accounts page would show their current subscription level and renewal options. However, it only shows basic user information to edit. The actual Accounts page is blank so I'm assuming it is automatically generated. I am running a Buddypress site with this. How can I have this information added to the Accounts.

Also, the members have not received communications to renew. Does anyone know why this would happen?

Thanks!

  • aecnu

    Greetings brandee,

    Thank you for the great questions.

    The account status portion on the members side will have to be a feature request if indeed it has not already been addressed in the newest Membership version 3.4 which has just been released - but due to WordPress 3.5 release and the commotion it has caused I have not had the opportunity to dig into Membership version 3.4 myself.

    Before upgrading be sure to backup, especially the database and something like the Snapshot plugin sounds like just the tool to get the job of backing up the databases done for you.

    Also, the members have not received communications to renew. Does anyone know why this would happen?

    Which payment gateway are you using for your memberships?

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings brandee,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

  • aecnu

    Greetings brandee,

    Thank you for letting me know some more details and if you are indeed not aware of the "serial and indefinite" settings then it is sure we have a setting wrong in there.

    In addition, all your installations are outdated by at least a version if not more and I anticipate trouble since all the plugins have been updated for WordPress 3.5 and Buddy Press 1.6.3

    Can you please get all these updated including Membership to 3.4.2 and then you can send me log in credentials if this issue persists after the updates.

    Please advise.

    Cheers, Joe

  • aecnu

    Greetings brandee,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU DEV Community Member!

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.