Activating API key

Hi I have a multisite setup installed with pro sites and wpmu dev plugins. It keeps asking me for my API key. I supply it and the page refreshes and shows my profile. As soon as I click to another page it brings me back and asks me for my API key again. Any ideas?

  • xaviemirmon
    • Site Builder, Child of Zeus

    What other WPMU Dev plugins have you installed in addition to Pro Sites? As far as I am aware the API for WPMU Dev is required only for Anti-Splog and White Label Videos. Do you have one of those plugins? I would start to look for the error there. I am running Pro Sites and it dosen't need the WPMU Dev API only the API's for your payment gateways like Paypal. Hope that helps!

    Xavier

  • 3SixtyEvolve
    • New Recruit

    @xaviemirmon and @mark77210, thanks for your input so far! Appreciate it.

    Hi @sixplusonemedia

    Are you logged in as Network Administrator when it's asking you to input your WPMU DEV API and on the network admin or on a sub-site? And on which plugin does this happen, or is it on the admin dashboard?

    Sorry for all the questions :slight_smile: Just trying to establish a base for our investigation.

    Look forward to your feedback.

    Have a good weekend!

    Gina

  • Chris Burke
    • Flash Drive

    Hi, no worries... It's on the main network admin panel, logged in as the super admin.

    Noticed that the API key is not getting stored in the database. I think it might have something to do with my nginx rewrite rules.

    After i asked the question i read another thread and I added the API key to the database manually and now I can't get into the admin as its trying to redirect me and the rewrites are causing a loop now.

  • Chris Burke
    • Flash Drive

    Okay got back into the admin, very strange, nothing saves to the database. This includes trying to activate any plugins (not just wpmu ones) or making changes to the site in general.

    Deactivated all plugins via the database and the admin starts working properly. Starting every plugin one by one works until I activate WPU Dev plugin which then stops saves to the database.

  • Chris Burke
    • Flash Drive

    Still not got this plugin working. I have tried deactivating all plugins on a fresh multisite install and activate only this plugin. It asks me for the API key, I enter it then it refreshes and displays my info. As soon as I navigate away it brings me back to this page asking for the API key.

    If I activate my other plugins first and then this one it runs out of memory (memory_limit: 128M in php.ini) and maxes out the CPU.

    Would really like to get this plugin working for the easy updating of the plugins.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.