Activating Membership 2 Pro slows down my site

I’m not sure why my site is loading really slow after activating M2P. I have the option to ‘Speed up results’ in Membership 2 > Settings > General enabled, so not sure what else can I do.

I tried deactivating all the other plugins and switching to 2017 theme, but the site is still loading strangely slow.

  • Ivan
    • Developer

    Hi galfanodesign !

    I've tested it with enabled and disabled the plugin and it seems it works with the same speed. Moreover, I've checked your site with Google PageSpeed Tools and it says - your server responded in 1.2 seconds in both cases. Have you resolved this issue yet? If no - could you provide more details what I've missed?

    Best,
    Ivan.

  • galfanodesign
    • Flash Drive

    Yes, I found a thread in your forum about disabling the media protection and that seemed to have done it. Ideally it would be nice to have that feature activated, since my client posts images that registered members get, and would be nice to have those be protected.

    Thanks!
    Dan

    • Ash
      • WordPress Hacker

      Yes, media protection may increase loading time a bit. Media protection is a complex algorithm as it needs to search for media files through the post content with a regex search. Though our developers are working on the improvement of the algorithm used for media protection. Hopefully, this will improve the site speed as well :slight_smile:

      Have a nice day!

      Cheers,
      Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.