Activating Plugins took site down

So, I was activating some WPMUDev plugins, and all of a sudden, Whamo! My site went down.
Please help!

  • Nastia
    • Support Rock Star

    Hello Justin , hope you're doing well!

    Please let us know what plugin you've activated last? Do you see any errors when you are trying to access your site, front end, and the back end?

    If you can't access the wp-admin of your site, please use FTP or File Manger to access the /wp-content/plugins/ directory.

    Rename the /plugins/ directory to something else, for example /plugins-deactivate/. Try to access the admin again, do not load the WP plugins admin. This will mean the plugin is active, no others are and you won’t need to deactivate each one and then have to activate them again later

    Create another new /plugins/ folder, and move the WPMU DEV plugins one at the time or in groups to test when the issue occurs again.

    Follow the testing principle from the flowchart:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it went!

    Cheers,
    Nastia

  • Justin
    • Site Builder, Child of Zeus

    Nastia,

    The WordPress dashboard is gone, along with my Cpanel and accompanying FTP accounts. All that's left is to SSH into the server itself, and honestly, that's a little beyond me...
    Any help or ideas would be appreciated.

  • Denitsa
    • WordPress Warrior

    Hey there Justin,

    How did you find out that your IP has been locked out? That's usually something the Defender plugin does, so did you have that one installed?

    It won't block your FTP access or cPanel, however, did you manage to get that one to work somehow? If not, you might want to ask your hosting provider about this issue as this is not usually connected to WordPress at all.

    If you got your FTP back, you could login to your site and temporarily disable Defender or all your plugins as Nastia explained above. The steps for disabling Defender only would be pretty much the same - you'd need to navigate to /wp-content/plugins/wp-defender and rename the directory to something else (i.e. wp-defender-disabled).
    You should now be able to login to WordPress, and you will receive a small error message indicating that the plugin failed to load.

    Afterwards, you can whitelist your IP from Defender's setting if you'd like by going to Defender -> IP Lockouts -> IP Blacklist and then typing your IP in the Whitelist field. This way you won't be locked out in the future, but keep in mind that your website will be accessible from your IP at all times.

    And here are some guides on how to use SSH if you'd like to try:
    https://mediatemple.net/community/products/dv/204403684/connecting-via-ssh-to-your-server
    https://www.siteground.com/tutorials/ssh/

    Let me know how it goes!

    All the best,
    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.