Activation email on Buddypress with Membership

I believe that BuddyPress is supposed to send and activation email upon registration.

I am using BuddyPress with Membership and this is not happening. The user is automatically logged in and no activation email is sent.

Any idea why this is not happening?

Thanks,

Joe

  • Joe
    • Site Builder, Child of Zeus

    Not really. At least not in me case. Maybe I have something wrong on my settings but for me, with BP and Membership, the user is presented with the account creation from BP first and after submitting the form, the subcription select buttom comes. Clicking anywhere brings up the page with the admin bar on top, meaning the user is already logged in. Without coming back from any gateway. Therefore the user is a visitor logged in not assigned to any subscription.

    Thanks,

    Joe

  • Joe
    • Site Builder, Child of Zeus

    Hello Tom,

    By setting the default user level (Free) to new user regisrtations (or to both user reg and stranger), when the user registers he is sent to the registration page (which is the page selected on the Membership Options tab). I have other subscriptions that show on this (Sign Up) page.

    I believe the user should be sent to the Welcome page selected on the “Registration Completed” option on the Membership Options tab.

    Thanks,

    Joe

  • Jack Kitterhing
    • Code Norris

    Hi there Joe,

    I hope you are well today and sorry about the delay here.

    Unfortunately as it currently stands BuddyPress won’t send an activation email when using Membership, as membership actually overrides that registration.

    I’ll move this to the features and feedback area for you, perhaps we can see what we can do with the registration process :slight_smile:

    Thank you!

    Kind Regards

    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.