Add location and Add provider do nothing

Another problem I just found out.
In the settings, I activated locations but clicking on "Add location" doesn't do anything. The same for "Add service provider". "Add service" works just fine.
Did I make a mistake somewhere? The rest of my setup seems fine...

  • PC
    • WPMU DEV Initiate

    Hey Fyod,

    Greetings and thanks for posting on the forums.

    Can you kindly provide me a bit of more info on how is it not working ?

    I just tried it on my lab site and was able to add a location fine.

    Can you kindly try and please check for a plugin conflict using the attached screenshot

    to see if there is a plugin causing that ?

    Cheers
    PC
    Sales &Support

  • pxwm
    • WP Core Meltdown

    Hi @Fyod

    Just to confirm:-

    Once you have activated either 'Service Locations' or 'Service Provider Locations' in the 'Add-ons' tab a new tab called 'Locations' is created.

    If you click on the 'Locations' tab you can then create one or more locations and also further down the page you can select an automatic or manually selection to show the dropdown for locations in the Appointment page.

    You then need to select the 'Services' or 'Service Provider' tab(s) depending on the Add-on you have activated and you should see a Blue link called 'More Info' underneath each Service/Service Provider.
    Clicking on this will allow you to assign a single location.

    You may also wish to view the following post as I'm looking to enhance the feature so you can assign more than one location to a Service/Service Provider similar to assigning a Service provider to one or more Services.
    https://premium.wpmudev.org/forums/topic/appointment-location-feature#post-482929

    Hope this helps
    Regards
    SteveB

  • Fyod
    • Flash Drive

    Ok it took some experimenting and time, but I found out that the error is caused by the language (I translated myslef).
    Could someone confirm (install) a random language file so I know if the error is mine? Interestingly enough, I only have about 3/4 of the translations showing, although the po file is almost fully translated. Looks like I'll go back and start with a new language .pot insted of upgrading it (1.2.8 > 1.3). Maybe the mistake happened there.

    Also, whenever I activate the locations addon, the App+ setting revert to default. Is this always the case?

  • Fyod
    • Flash Drive

    Iirc, all of them. Although this could've been caused by the same mystery problem as with the links (even the 'More info' link under a service wasn't functioning).
    In relevance to the problem, should I be translating the .pot thats included in the languages folder, or updating and older .pot? Does the .pot in 1.3 include all needed phrases?
    I just tried a brand new translation of the .pot, only about ten Locations phrases and uploaded the po/mo, and so far everything is ok in the Locations addon.

    Edit: just noticed the language file in the latest update doesn't include settings tab titles for example. So I suspect this isn't a full updated language file. Where can I get one?

  • PC
    • WPMU DEV Initiate

    Hey there,

    Thanks for posting back.

    I'm still having a problem with the General settings reverting to default when I make any change (and save) in Locations. With or without the language file.

    I have been able to successfully replicate this issue on my lab site and have sent a note to our lead developer @Vladislav so that we can get this fixed.

    He should be here sooner than later.

    Cheers
    PC
    Sales &Support

  • Fyod
    • Flash Drive

    Thanks :wink:
    I also noticed that once the Locations plugin is activated, if you go to FAQ > Click here to replay the settings tutorial - you will be redirected to the settings page, but the tutorial doesn't show any more.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.