Adding a New Site to Multisite

Good Day,
I am having extreme difficulty getting the URL correct when I try to add a new site. I am unsure how to add the URL in the appropriate window. I have attached a screenshot of what it states when I go to domain mapping. After I add my site, I cannot actually "go" to the site that I just added. Please let me know what I am doing incorrectly? Thank you so much! Theresa

  • Kasia Swiderska

    Hello Theresa,

    This error message states that your sunrise.php file is not updated or define('SUNRISE', 'on'); is in the wrong place of the wp-config.php file.

    Please check if this line is in right places. It should be above

    /* That's all, stop editing! Happy blogging. */

    Also I can see that you have two Domain Mapping positions in the menu - is there only one plugin for that installed?

    Would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Rupok

    Hi Theresa, hope you had a wonderful day.

    You will see in the /domain-mapping/ folder there is a file called sunrise.php. We need to move that (move, not copy) to the /wp-content/ folder. Just to make sure we are on the same page, can you please confirm you did this?

    Now you just need crack open your wp-config.php file located within the root of your WordPress installation. You will have to enter the following line:
    define( 'SUNRISE', 'on' );
    You can pop that right under the WP_DEBUG option, so like this:

    define('WP_DEBUG', false);
    define( 'SUNRISE', 'on' );

    If for some reason you don’t have the WP_DEBUG line, then providing it is just above the following code comment it should work well:
    /* That's all, stop editing! Happy blogging. */

    Please let us know if you are getting the same error even after completing this two. We will be glad to investigate further. And another thing, can you try doing this in another server which is public and a FQDN is pointed to that server? Because domain mapping has lots of things to do with "domains" as the name suggests. "localhost" is a nice hostname, but it's not FQDN (fully qualified domain name).

    I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.