Adding A Search Box Using Better Search Plugin

I removed the search box that came with the theme because it wasn't returning any acceptable results. I've downloaded the Better Search plugin and would like to add a search box using it to the footer where the old search box was. I was hoping it would be a draggable element in Upfront, but I don't see it.
I did drag a widget onto a page and selected Better Search form from the drop down.
Worse than its appearance, however, is the fact that it still takes me to the Search Scribe results page. And worst of all, it doesn't return any results for "slavery" for instance, which is rather prominent on our site. I have pages, posts, and attachments selected in the settings menu for the plugin.
Next steps?
Thanks.

  • Adam Czajczyk

    Hello Joe,

    I hope you're having a nice day!

    I've just installed the Better Search plugin on my own test setup with recent Scribe enabled and then, following your example, placed its search form inside the footer. I agree it doesn't look good (fortunately this can be fixed with another snippet of "magic css") but I was able to search through my posts quite accurately.

    I can see that there's quite a bit of setting for the plugin but I admit I'm not sure why it's ignoring the posts on your site. That said, I'd like to take a closer look at your setup. Would you mind granting me a support access to your site via our WPMU DEV Dashboard plugin?

    To do so, please follow this guide and let me know here:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Joe,

    I'm terribly sorry for the inconvenience but I still keep getting the same error. Although an "Invalid token" message happens sometimes it rarely keeps coming up after support access has been extended/re-granted. That said, could you please do the following:

    - remove access at all
    - clear cache in case you're using any cache plugin (e.g. W3 Total Cache or similar)
    - make sure that the WPMU DEV Dashboard plugin is updated (an important update has just been released today!)
    - grant access again

    Let me know here please and I'll give it one more try. Hopefully, this will work, otherwise I'll just ask you to contact me directly.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Joe,

    Thanks for taking care of support access, it's working now!

    I've visited and checked your site. I added the Better Search form to the footer (the way you did it previously, which is a correct way) and checked searches. To my opinion, it's working as it should and will not differ very much from default WP search form if it comes to results.

    The issue here is that no search returns results for "slavery" term on your site. That's not related to Upfront in any way. If you could switch for a moment to the Twenty Fifteen theme you'd find out that it's not returning any results for the term as well. The same happens when you search in admin dashboard with search filed above the post list.

    I've noticed that there's no "slavery" word in any of the titles or tag sets of your posts. It also seems that this word may not be used in content. Search with a "slave" term instead brings single post - with default theme, Scribe, default search and Better Search form, that's the same.

    That said, my suggestion would be first to make sure that the "slavery" term (which is important for your site) was used inside posts/post titles/tags. Both default and plugin's search will then return results.

    As for search result page and form. This should be editable with Upfront editor and most likely some custom css. If you could share a bit more detailed idea on how this should look like, I could help you with this.

    Best regards,
    Adam

  • Joe

    Thanks, Adam. I really appreciate the effort you are putting into this. Three things:
    1. "slavery" is in the third paragraph of the home page, yet it brings up no results.
    2. The search results are shown on a page that has "Search Scribe" as the title and a region designated "Request a Quote." Not exactly what I'm looking for on my site.
    3. If I search "slaves" and click on the arrow in the lower left part of the page, it takes me to an odd version of my home page--no header, fonts and backgrounds different, and gibberish for text after starting off with what's really there.

    All in all, I don't think this is ready for prime time, even if I can find a way to edit the search results page using Upfront.

    And now, when I pull up Upfront, on my home page, the photos in the slider are not visible. If I hover the cursor, I see there's a box there, but when I move the cursor away, it appears to be a blank area.
    THIS IS NOT GOOD.

  • Joe

    And here's what I see when I launch Upfront.

    The slider on the home page seems to be working on line. I just can't see it in Upfront. Similar to the "like" box for Facebook. (See previous post.)
    What's odd (to me) is that when I first click on Upfront, the first picture in the slider appears, then when the screen shows the connect-the-dots loading icon and then comes back up, the photo is gone.

  • Adam Czajczyk

    Hello Joe,

    Thank you for your response. Let me please address it "one by one" :slight_smile:

    1. "slavery" is in the third paragraph of the home page, yet it brings up no results.

    I checked your site. The text on the home page was added with Upfront's "text element". This is not a content in terms of WordPress engine. Rather than that, that's a "layout part" and as such cannot and will not be indexed/picked up by WordPress search (or Better Search which works pretty much the same way, except results presentation).

    If the word "slavery" was present in content of any of your posts or WP pages, it would be returns on search results list.

    Alternatively, it's possible to create a page in WordPress (as any other page on "Pages -> Add new" page in dashboard), put the homepage text there and then go to "Settings -> Reading" dashboard section and set this page as a "Front page". You could edit it's layout then the same way you do it currently but also WP search engine (as well as Better Search) should start noticing the "slavery" content I think.

    2. The search results are shown on a page that has "Search Scribe" as the title and a region designated "Request a Quote." Not exactly what I'm looking for on my site.

    You can change it via Upfont editor. Open your site in browser, perform any search and a search result page will come up. Once it's loaded click on "Upfront" link in an admin toolbar and an Upfront editor will load. You can now both edit the page title (double click on it and you'll be able to change the text) and remove the "Request quote" region.

    3. If I search "slaves" and click on the arrow in the lower left part of the page, it takes me to an odd version of my home page--no header, fonts and backgrounds different, and gibberish for text after starting off with what's really there.

    This takes to a page with no title and this is NOT your hompage. It's page listed on "Pages -> All pages" page (ID: 70) that's "left alone" there: it's not set as a homepage (see above) and not linked from anywhere.

    Given all this what I'd do would be:

    1. Give a title to the page I mentioned above (e.g. named it "Homepage")
    2. Set it as a "Front page'" on "Settings -> Reading" options page
    3. Opened it in browser and then using Upfront editor added slider and all other layout elements to it
    4. Went to search result page and entered Upfront editor (as described earlier) and adjust it to my needs
    5. The custom CSS for search form will have to be added but I'll gladly help you with this.

    As for slider. I can confirm this unfortunately. Could you please start a separate thread on this as it needs further troubleshooting? It would help us a lot to diagnose and fix the issue.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.