Adding Domain to Domain Mapping Issue

Hi, I installed the Domain Mapping plugin and configured everything.

I went to NETWORK Admin to add the site and parked the domain on Cpanel. When I tried to Map the domain under the "test.mydomain.com" to " mappeddomain.com" , I got nothing.

  • Jack Kitterhing
    • Code Norris

    Hi there @envisionmt,

    Hope you're well today and thanks for your question.

    Can you let me know what domain your trying to add please?

    Also can you check you have a dedicated IP, when you load your dedicated IP it should point to the root of your multisite install.

    The domain your trying to map should have a A record pointing to that dedicated IP.

    Thanks!

    Kind Regards
    Jack.

  • Jack Kitterhing
    • Code Norris

    Hi there @envisionmt,

    Hope you're well today! :slight_smile:

    Would it be possible for you to try using A records?

    I've just checked and saw this in your network admin > sites, under domain mapping.

    Parse error: syntax error, unexpected T_STATIC in /home/fbgame/public_html/wp-content/plugins/domain-mapping/classes/Vendor/Punycode.php on line 75

    Yet I don't get that on my own install, can you send through the following please?

    - In the subject field add "Attn: Jack Kitterhing"
    - Link back to this thread
    - Include admin/network access
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thank you!

    Kind Regards
    Jack.

  • Vaughan
    • Support/SLS MockingJay

    Hi,

    Parse error: syntax error, unexpected T_STATIC in /home/fbgame/public_html/wp-content/plugins/domain-mapping/classes/Vendor/Punycode.php on line 75

    I'm pretty sure this is due to the PHP version you are using, most likely PHP 5.2

    The solution is to open up Punycode.php & change all references to static:: to self::

    But the recommended solution would be to upgrade your PHP to at least the latest version of PHP 5.3.x, Your host should be able to help with that.

    If upgrading PHP is not an option, I have edited this file for you.

    download and unzip the attached file.

    Then upload the Punycode.php file to

    /wp-content/plugins/domain-mapping/classes/Vendor/

    overwrite the existing file.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.