Adding monthly calendar shortcode twice results in blank page

Hi,

If i add the shortcode for the monthly calendar twice in a page on my website, the whole content area only the goes blank and there is no output at all, even the content above and below the shortcode is gone. Example: http://www.massagehuys.nl/deep-detox-massage/
I need to add it twice to show the current month's calendar as well as the next month. Do you have any idea how to solve this?

kind regards,

Hidde Braun, Amsterdam

  • Patrick
    • Support Monkey

    Hi there @Hidde

    Welcome to the forums, glad to have you aboard!

    You may have simply forgotten an opening or closing bracket. Would you please double-check to be sure you have added both as separate instances of the shortcode, like so:

    [app_monthly_schedule]
    [app_monthly_schedule add="1"]

    Thanks!

  • Ash
    • WordPress Hacker

    Hello @Hidde

    I have just tested and double shortcode just worked fine for me.

    Would you please enable debug mode and check if any error is shown in that page?

    To enable debug mode please edit a line in your wp-config.php:
    Change

    define('WP_DEBUG', false);

    to

    define('WP_DEBUG', true);

    Please let us know what errors you see there.

    Cheers
    Ash

  • Hidde
    • New Recruit

    I switched on debug mode, and no error is shown. However if i set error reporting in PHP to E_ALL ~ E_NOTICE and show errors to "on" in php.ini, the following error appears in the error log of webserver:

    Strict Standards: Redefining already defined constructor for class AppointmentsGcal in /var/www/vhosts/massagehuys.nl/httpdocs/wp-content/plugins/appointments/includes/class.gcal.php on line 26

  • Ash
    • WordPress Hacker

    Hello @Hidde

    This is not an error in fact, just a notice. You can turn debug mode off now.

    If you use the shortcode once, does it work then? If it works, then please enable support access and share me a link of the page where I need to take a look.

    Cheers
    Ash

  • Ash
    • WordPress Hacker

    Yes, and I don't even see any js error in your previous page.

    If you have any caching plugin, please reset cache and check.

    Can you create another page for that provider? Also make sure you put the shortcode in TEXT mode and not in VISUAL mode.

    Otherwise, you can enable support access from WPMU DEV > Support so that I can take a look.

    Cheers
    Ash

  • Hidde
    • New Recruit

    Hello Ash,

    Thanks for your support. You're right it's not an error so that can't be it.
    I tried to debug this even further bij removing all content above the shortcodes, and then it works!
    So i deleted line by line (saving and previewing after every change) and apparently this line breaks te page:

    <a href="http://www.massagehuys.nl/wp-content/uploads/2014/09/massagehuys_079.jpg"><img class="alignleft" src="http://www.massagehuys.nl/wp-content/uploads/2014/09/massagehuys_079-1024x682.jpg" alt="Massage" /></a>

    Pretty strange huh? Any idea why this line breaks? Apparently some other plugin?

    cheers,

    Hidde

    Update: If i remove the link surrounding the image, it works. I don't really need to link to the image attachment so this is a quickfix, but i really want to know why it breaks... grrrr.

  • Ash
    • WordPress Hacker

    Haha. I really don't have any idea. With that text it's working fine for me!

    It might be a plugin conflict, but it's really weird. If you deactivate all other plugins does it work?\

    Also, if you use same line in any other page with the shortcode does it work?

    Cheers
    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.