Adding users and sites in multi-domain / domain mapping

Howdy,

I've installed the latest WP, then went through all the steps to setup multisite. It only took about 14 tries, but it worked.

Now I'd like to add users to their sites(blogs), but when I try to set them up they just end up as a user on the network administration blog. I'm also unable to login to their accounts as the super. The last piece of the puzzle is "what URL do I give them if they just want to login to their own site(blog)?

To be specific, I have many clients that each have their own domain. The multisite version was installed as "subdomain" though I would prefer "subfolder." The purpose is to give one site(blog) to each domain. Each has its own user, with no subusers. No users share access to other users' blogs, and users may not set up additional blogs other than the one I gave them.

As the superadmin, I am trying to lock down most of the "admin" features/plugin installation/them modification, then give them a simplified version ("Easy Blogging" - already installed).

To be honest, I'm new to WP but not new to programming and site management. There's nothing intuitive about the menus...I can't really tell where I am or what I'm doing. Maybe I need to have a spa day or something! :wink:

Best,
Tony

p.s. sorry for the site/blog verbiage. it's come to my attention that WP recently updated their terminology, so I used both to hopefully be more clear.

  • xaviemirmon

    Hi @tonyfantis,

    To add users to their blog go to http://YOURSITE/wp-admin/network/ this takes you to the network admin page you will then go to Sites>All Sites. From there you will see a list of all your sites and their respected users. To add a user to a site hover over the site you would like to edit and go to Edit>Users you will then be able to add the users you have already created. Make sure to give them the role administrator or they won't be able to edit their sites correctly you can still lock them in easyblogging later. To tackle the site domains you will have to install domain mapping. If you aren't too far along you can reinstall subdirectory install and that does is subfolders instead of subdomains. Their login URL will be http://THEIRSUBDOMAIN.YOURSITE/wp-admin/ the way it's currently setup. Hope that helps!

    Xavier

  • Arun Basil Lal

    Hey Tony,

    Welcome to the Community!

    So you have multisite installed and the domain mapping plugin installed as well? https://premium.wpmudev.org/project/domain-mapping/

    Go to Network Settings and make sure that user registration is enabled. Also tick "Allow site administrators to add new users to their site via the "Users ? Add New" page." See the screenshot attached.

    Now the url you need to give to the site admins would be: Theirsite.com/wp-admin

    They would be asked to login or they can register and as a user and then get started.

    Hope this helps.

  • tonyfantis

    Thanks, Xavier and Arun. Both of you offered some great tips.

    I've been scouring the interwebs for two days to hire a Multisite expert with no luck. The buzz seems to be there are thousands of WP developers our there. Maybe they're like the Munchkins in Munchkinland from the Wizard of Oz...hiding in flower beds! :wink:

    Xavier, the recommendation to add them as "Admin" was great. I had been adding them as editors because those roles seemed to be exactly what I was looking for. They weren't, and your suggestion was great. =)

    Arun, the user registration hint was also good. I had that turned off, because I don't want people to be able to "register." I wanted to have full control over new users and "register" them myself. This turned out to be another counterintuitive process, so thanks for your help!

  • Kimberly

    Hi!

    Just checking in :slight_smile:

    I'm guessing that because we haven't heard back from you that you've got your issue worked out via live chat or email, or that we have reached the end of our convo here. If you are still having problems or need any other answers on this particular topic please feel free to come back to this thread at anytime. Just be sure to mark it Not Resolved so we don't miss it!

    This ticket is only being Resolved due to lack of activity. It is by no means an action to avoid, brush off or minimize your issue. We are ready and here if you want to re-open at any time and I apologize in advance for any lack of communication if this ticket is being closed in error.

    Thanks for being part of the WPMU DEV Community!

    Best,
    Kimberly

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.