Additional fields (Add-on) don't appear when manually adding appointment

I'm using the "Additional fields" Add-on to add some extra fields for my appointment form. These appear on the front end just fine.

When I try to manually add an appointment in the WordPress backend, these additional fields I added do not show up for me. How can I make them show up?

  • Michael Bissett
    • Recruit

    Hey @Stefan, hope you're doing well this evening! :slight_smile:

    Hmm... I'm curious, do you have the box for "Allow admin-side fields editing" checked inside of:

    Appointments -> Settings -> General

    I've got that checked over on my test site, and I'm seeing that I'm able to edit the additional field information, both when I'm adding a new appointment, as well as when I'm editing an existing one.

    Please advise,
    Michael

  • Stefan
    • Flash Drive

    I have a second question.

    The e-mail macro / placeholder I use in my emails does not work / display in the emails that go out when I add appointments on the admin-side.

    For example, I have a text field called "Number of people going." The "E-mail macro:" is "FIELD_NUMBEROFPEOPLEGOING"

    I use this macro in an email the client receives, but the client does not see what was put in that form - they just see "FIELD_NUMBEROFPEOPLEGOING"

    Attaching images to show what I mean.

  • Michael Bissett
    • Recruit

    Hey @Stefan, thanks for your patience here! :slight_smile:

    I do see what you mean here, as I'm able to replicate this over on my own end. I've reported this to the developer, but in the meantime, you should be able to get this to work if you uncheck the box to send the confirmation, save the appointment, check the confirmation box, and save again.

    It seems like when that box is checked, while other details get saved, the additional fields information doesn't. :disappointed:

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.